Merge changes from topic "mp/giv3-discovery" into integration
authorSoby Mathew <soby.mathew@arm.com>
Fri, 27 Sep 2019 09:42:37 +0000 (09:42 +0000)
committerTrustedFirmware Code Review <review@review.trustedfirmware.org>
Fri, 27 Sep 2019 09:42:37 +0000 (09:42 +0000)
* changes:
  Migrate ARM platforms to use the new GICv3 API
  Adding new optional PSCI hook pwr_domain_on_finish_late
  GICv3: Enable multi socket GIC redistributor frame discovery

1  2 
docs/getting_started/porting-guide.rst

index 97ed1fa43a107667702765a2070010c2ffd77fd3,af36b6a5f208bbdc8b27a36b35195ed2e1e6907f..9eb7c17e15c2827ce287b2674375c014b3f3c81e
@@@ -546,13 -546,6 +546,13 @@@ optionally be defined
     PLAT_PARTITION_MAX_ENTRIES := 12
     $(eval $(call add_define,PLAT_PARTITION_MAX_ENTRIES))
  
 +-  **PLAT_PARTITION_BLOCK_SIZE**
 +   The size of partition block. It could be either 512 bytes or 4096 bytes.
 +   The default value is 512.
 +   `For example, define the build flag in platform.mk`_:
 +   PLAT_PARTITION_BLOCK_SIZE := 4096
 +   $(eval $(call add_define,PLAT_PARTITION_BLOCK_SIZE))
 +
  The following constant is optional. It should be defined to override the default
  behaviour of the ``assert()`` function (for example, to save memory).
  
@@@ -2209,6 -2202,19 +2209,19 @@@ immediately before the CPU was turned o
  above the CPU might require initialization due to having previously been in
  low power states. The generic code expects the handler to succeed.
  
+ plat_psci_ops.pwr_domain_on_finish_late() [optional]
+ ...........................................................
+ This optional function is called by the PSCI implementation after the calling
+ CPU is fully powered on with respective data caches enabled. The calling CPU and
+ the associated cluster are guaranteed to be participating in coherency. This
+ function gives the flexibility to perform any platform-specific actions safely,
+ such as initialization or modification of shared data structures, without the
+ overhead of explicit cache maintainace operations.
+ The ``target_state`` has a similar meaning as described in the ``pwr_domain_on_finish()``
+ operation. The generic code expects the handler to succeed.
  plat_psci_ops.pwr_domain_suspend_finish()
  .........................................