pdns: correct incomplete fix for build failure
authorJames Taylor <james@jtaylor.id.au>
Wed, 3 Jul 2019 10:23:45 +0000 (20:23 +1000)
committerEneas Queiroz <cotequeiroz@gmail.com>
Wed, 3 Jul 2019 14:51:36 +0000 (11:51 -0300)
Maintainer: me

This commit addresses a build failure around guards on execinfo.h usage to
prevent uclibc from pulling it in, as it defines both  __GLIBC__ and __UCLIBC__.
The original patch had invalid syntax which this corrects.

Signed-off-by: James Taylor <james@jtaylor.id.au>
net/pdns/Makefile
net/pdns/patches/500-fix-uclibc-pretending-to-be-glibc.patch

index 8bc80535a6c5989046e1601456bddd06fb33cf7d..09b204b125a4fe60db6087bd8dac046b6292de66 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pdns
 PKG_VERSION:=4.1.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
index 437b36ba45b7c82036d4466daed90d3905adb4dd..f3d10208ed9783b7dc33bd8397b286cbd0638df6 100644 (file)
@@ -17,7 +17,7 @@ index e6686787b3..209db7af89 100644
  }
  
 -#ifdef __GLIBC__
-+#ifdef __GLIBC__ && !defined(__UCLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
  #include <execinfo.h>
  static void tbhandler(int num)
  {
@@ -26,7 +26,7 @@ index e6686787b3..209db7af89 100644
    s_starttime=time(0);
  
 -#ifdef __GLIBC__
-+#ifdef __GLIBC__ && !defined(__UCLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
    signal(SIGSEGV,tbhandler);
    signal(SIGFPE,tbhandler);
    signal(SIGABRT,tbhandler);
@@ -35,7 +35,7 @@ index e6686787b3..209db7af89 100644
      // we really need to do work - either standalone or as an instance
  
 -#ifdef __GLIBC__
-+#ifdef __GLIBC__ && !defined(__UCLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
      if(!::arg().mustDo("traceback-handler")) {
        g_log<<Logger::Warning<<"Disabling traceback handler"<<endl;
        signal(SIGSEGV,SIG_DFL);