Merge pull request #3258 from diizzyy/patch-9
authorHannu Nyman <hannu.nyman@iki.fi>
Mon, 3 Oct 2016 09:42:05 +0000 (12:42 +0300)
committerGitHub <noreply@github.com>
Mon, 3 Oct 2016 09:42:05 +0000 (12:42 +0300)
netdata: disable atomic instructions

admin/netdata/Makefile

index 38b2837b97fa070dfa5e25ed64121b6f450bc2a2..a15e59d16e063c755fc53249788feaae0fea293c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netdata
 PKG_VERSION:=1.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MAINTAINER:=Sebastian Careba <nitroshift@yahoo.com>
 PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=COPYING
@@ -22,6 +22,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_INSTALL:=1
 PKG_FIXUP:=autoreconf
 
+TARGET_CFLAGS+= -DNETDATA_NO_ATOMIC_INSTRUCTIONS=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/netdata