[libs] zaptel-1.4.x: Added hotplug script to create correct Zaptel device nodes ...
authorDaniel Dickinson <crazycshore@gmail.com>
Tue, 22 Mar 2011 00:35:30 +0000 (00:35 +0000)
committerDaniel Dickinson <crazycshore@gmail.com>
Tue, 22 Mar 2011 00:35:30 +0000 (00:35 +0000)
SVN-Revision: 26262

libs/zaptel-1.4.x/Makefile
libs/zaptel-1.4.x/files/10-create-device-node [new file with mode: 0644]

index 631d4d7c0669113dc2c6082f522b4a3fc352d50c..91f19583ee4e60583f34018ba3b8e02756d9765c 100644 (file)
@@ -155,6 +155,8 @@ define Package/zaptel14-util/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ztmonitor $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ztscan $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ztspeed $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/zaptel
+       $(INSTALL_DATA) ./files/10-create-device-node $(1)/etc/hotplug.d/zaptel/
 endef
 
 define Package/zaptel14-libtonezone/install
diff --git a/libs/zaptel-1.4.x/files/10-create-device-node b/libs/zaptel-1.4.x/files/10-create-device-node
new file mode 100644 (file)
index 0000000..f49c6c1
--- /dev/null
@@ -0,0 +1,9 @@
+#!/bin/sh
+case "$ACTION" in
+        add)
+                /bin/mkdir -p /dev/zap
+                /bin/mknod -m 0644 /dev/zap/${DEVICENAME#zap} c $MAJOR $MINOR
+                ;;
+esac
+