cmus: make OSS configurable
authorPeter Wagner <​tripolar@gmx.at>
Mon, 29 Jul 2013 18:36:00 +0000 (18:36 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Mon, 29 Jul 2013 18:36:00 +0000 (18:36 +0000)
Signed-off-by: Peter Wagner <tripolar@gmx.at>
SVN-Revision: 37614

sound/cmus/Config.in
sound/cmus/Makefile

index ac51088b2288a6f09bd285f0e1264e9a8906b673..f143133d82d81c5f1cb668823176376da24b0508 100644 (file)
@@ -3,7 +3,10 @@ menu "Configuration"
 
 config CMUS_WITH_PULSE
        bool "Enable pulseaudio support"
-       depends on PACKAGE_pulseaudio-daemon
+       default n
+
+config CONFIG_CMUS_WITH_OSS
+       bool "Enable OSS support"
        default n
 
 endmenu
index 391fd8f07753008df2d2f121d2a80fb1f3fdc24c..1b90ed7c9fc919d7e81bd919735af23c3ba15af3 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cmus
 PKG_VERSION:=2.5.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/cmus
@@ -28,7 +28,8 @@ define Package/cmus
   DEPENDS:= \
        +libpthread +librt +libncursesw $(ICONV_DEPENDS) \
        +AUDIO_SUPPORT:alsa-lib \
-       +BUILD_PATENTED:libmad +libvorbisidec +libflac
+       +BUILD_PATENTED:libmad +libvorbisidec +libflac \
+       $(if $(CONFIG_CMUS_WITH_PULSE),+pulseaudio-daemon,) 
 
   TITLE:=C* Music Player
   MAINTAINER:=Peter Wagner <tripolar@gmx.at>
@@ -40,6 +41,7 @@ define Package/cmus/config
   source "$(SOURCE)/Config.in"
 endef
 
+
 define Package/cmus/description
        C* Music Player is a modular and very configurable ncurses-based
        audio player. It has some interesting features like configurable
@@ -74,7 +76,7 @@ define Build/Configure
                CONFIG_ALSA=$(if $(CONFIG_AUDIO_SUPPORT),a,n) \
                CONFIG_AO=n \
                CONFIG_ARTS=n \
-               CONFIG_OSS=y \
+               CONFIG_OSS=$(if $(CONFIG_CMUS_WITH_OSS),a,n) \
                CONFIG_SUN=n \
                CONFIG_WAVEOUT=n \
                DEBUG=0 \