net/iputils: fix ping & arping under brcm47xx.
authorAlexandros C. Couloumbis <alex@ozo.com>
Wed, 23 Mar 2011 20:02:00 +0000 (20:02 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Wed, 23 Mar 2011 20:02:00 +0000 (20:02 +0000)
SVN-Revision: 26278

net/iputils/Makefile

index fdf0d2d9034a3e27523f1fcc3b58b830ebc0be3a..8039bf5fc36d39d74f107d8a49d299e5191de757 100644 (file)
@@ -121,6 +121,9 @@ define Package/iputils-traceroute6/description
   Traces path to a network host (IPv6).
 endef
 
+ifeq ($(BOARD),brcm47xx)
+  TARGET_CFLAGS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall
+endif
 
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS)" \