libpcap: fix library packaging issues
authorJo-Philipp Wich <jo@mein.io>
Tue, 5 May 2020 22:47:55 +0000 (00:47 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 5 May 2020 22:51:35 +0000 (00:51 +0200)
Workaround a bug in patches/100-debian_shared_lib.patch - it attemptss to
extract the library major version from debian/changelog which does not exist
in the vanilla upstream tarball.

Create a fake changelog file for now to satisfy the version extraction
routine until we get around to properly augment the patch.

Fixes: FS#2970
Fixes: 96ee7c8bfd ("libpcap: Update shared-lib patch from Debian to fix linking problems")
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/libs/libpcap/Makefile

index e6d9ee75b371b5909976027aba1e2f7301de3092..c42fa86cdd97ce886b6a19e49ca7d5820238199f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libpcap
 PKG_VERSION:=1.9.1
-PKG_RELEASE:=2
+PKG_RELEASE:=2.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.us.tcpdump.org/release/ \
@@ -84,6 +84,10 @@ define Build/Configure
        $(if $(CONFIG_PCAP_HAS_USB),,$(SED) 's/pcap-usb-linux.c *//' $(PKG_BUILD_DIR)/Makefile)
        $(if $(CONFIG_PCAP_HAS_BT),,$(SED) '/^#define PCAP_SUPPORT_BT/D' $(PKG_BUILD_DIR)/config.h)
        $(if $(CONFIG_PCAP_HAS_BT),,$(SED) 's/pcap-bt-linux.c *//' $(PKG_BUILD_DIR)/Makefile)
+
+       # Workaround https://bugs.openwrt.org/index.php?do=details&task_id=2970
+       mkdir $(PKG_BUILD_DIR)/debian
+       echo "libpcap (1-0)" > $(PKG_BUILD_DIR)/debian/changelog
 endef
 
 define Build/InstallDev