IPv6 support should depend on if we've enabled it
authorImre Kaloz <kaloz@openwrt.org>
Wed, 9 Oct 2013 11:03:00 +0000 (11:03 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Wed, 9 Oct 2013 11:03:00 +0000 (11:03 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 38349

package/libs/libpcap/Makefile

index f1d287225454a4bdf37b5f742f646f2d1f8e490b..24b07c932b5f6cd8400e39d513cb7b90c754a902 100644 (file)
@@ -54,7 +54,6 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
        --disable-yydebug \
-       --enable-ipv6 \
        --with-build-cc="$(HOSTCC)" \
        --with-pcap=linux \
        --without-septel \
@@ -62,6 +61,11 @@ CONFIGURE_ARGS += \
        --without-libnl \
        --disable-can
 
+ifeq ($(CONFIG_IPV6),y)
+CONFIGURE_ARGS += \
+       --enable-ipv6
+endif
+
 MAKE_FLAGS += \
        CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include"