klish: Fix build errors with external toolchains
authorFlorian Fainelli <f.fainelli@gmail.com>
Mon, 5 Jun 2017 20:41:00 +0000 (13:41 -0700)
committerFlorian Fainelli <f.fainelli@gmail.com>
Tue, 6 Jun 2017 00:18:51 +0000 (17:18 -0700)
We would first not be able to properly detect libxml2 because it's not
automatically found, fix that by explicitly linking against it (and zlib
a dependency). Then if we don't don't define X_OPEN_SOURCE=500, we would
run into the following build error:

clish/shell/shell_execute.c: In function 'clish_shell_exec_action':
clish/shell/shell_execute.c:309:18: error: 'sigignore' undeclared (first
use in this function)
  sa.sa_handler = sigignore; /* Empty signal handler */
                  ^
clish/shell/shell_execute.c:309:18: note: each undeclared identifier is
reported only once for each function it appears in

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
utils/klish/Makefile

index 4374e276bb25e87079b15eca6d9721360ef77acd..0a63a1053b7f3a6637f29412666ff00bd39eb088 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=klish
 PKG_VERSION:=2.1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://libcode.org/attachments/download/66/
@@ -50,6 +50,9 @@ define Package/klish/description
  More information about these tools is to be found on the klish web site.
 endef
 
+TARGET_LDFLAGS += -lxml2 -lz
+TARGET_CFLAGS += -D_XOPEN_SOURCE=500
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-libxml2 \