sslh: update to 1.21c 13227/head
authorRosen Penev <rosenp@gmail.com>
Fri, 28 Aug 2020 00:14:51 +0000 (17:14 -0700)
committerRosen Penev <rosenp@gmail.com>
Fri, 28 Aug 2020 00:32:06 +0000 (17:32 -0700)
Refresh patches. Remove now pointless format patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/sslh/Makefile
net/sslh/patches/001-no_sslh_select.patch
net/sslh/patches/002-configfile-fix.patch
net/sslh/patches/010-format.patch [deleted file]

index 5df307a91b70cd46f47e7f25a76bdce0c384755b..cb9282e8fc158a18df179b5a5cad400145fdbed6 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sslh
-PKG_VERSION:=v1.20
-PKG_RELEASE:=3
+PKG_VERSION:=v1.21c
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://rutschle.net/tech/sslh/
-PKG_HASH:=a7f49b0a1cfcb7bb9d97f5ffa932bff11c5f65d9a9bd8fe1812481dee5855116
+PKG_HASH:=3bfe783726f82c1f5a4be630ddc494ebb08dbb69980662cd7ffdeb7bc9e1e706
 
 PKG_MAINTAINER:=Jonathan McCrohan <jmccrohan@gmail.com>
 PKG_LICENSE:=GPL-2.0-or-later
index 3f547d2cb228c67377a6307a59fb3feb2c3b170d..1d3b3feffdb7bec15301dd1492ccd7f130693a0c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -68,7 +68,7 @@ all: sslh $(MAN) echosrv $(CONDITIONAL_T
+@@ -76,7 +76,7 @@ all: sslh $(MAN) echosrv $(CONDITIONAL_TARGETS)
  version.h:
        ./genver.sh >version.h
  
@@ -9,7 +9,7 @@
  
  $(OBJS): version.h
  
-@@ -76,10 +76,6 @@ sslh-fork: version.h $(OBJS) sslh-fork.o
+@@ -87,10 +87,6 @@ sslh-fork: version.h $(OBJS) sslh-fork.o Makefile common.h
        $(CC) $(CFLAGS) $(LDFLAGS) -o sslh-fork sslh-fork.o $(OBJS) $(LIBS)
        #strip sslh-fork
  
@@ -20,8 +20,8 @@
  systemd-sslh-generator: systemd-sslh-generator.o
        $(CC) $(CFLAGS) $(LDFLAGS) -o systemd-sslh-generator systemd-sslh-generator.o -lconfig
  
-@@ -115,7 +111,7 @@ distclean: clean
-       rm -f tags cscope.*
+@@ -127,7 +123,7 @@ distclean: clean
+       rm -f tags sslh-conf.c sslh-conf.h cscope.*
  
  clean:
 -      rm -f sslh-fork sslh-select echosrv version.h $(MAN) systemd-sslh-generator *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info
index 0c88cc6a61b751890fea7390cad20b3ffa04cfdd..d9344cdaa2a50363d4f0a4b51c65757e0ccf2873 100644 (file)
@@ -25,6 +25,6 @@
 -     { name: "http"; host: "localhost"; port: "80"; },
 +#     { name: "xmpp"; host: "localhost"; port: "5222"; },
 +#     { name: "http"; host: "localhost"; port: "80"; },
-      { name: "ssl"; host: "localhost"; port: "443"; log_level: 0; },
+      { name: "tls"; host: "localhost"; port: "443"; log_level: 0; },
       { name: "anyprot"; host: "localhost"; port: "443"; }
  );
diff --git a/net/sslh/patches/010-format.patch b/net/sslh/patches/010-format.patch
deleted file mode 100644 (file)
index a252905..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/sslh-main.c
-+++ b/sslh-main.c
-@@ -167,7 +167,7 @@ void cmd_ssl_to_tls(int argc, char* argv[])
-             strcpy(argv[i], "--tls");
-             /* foreground option not parsed yet, syslog not open, just print on
-              * stderr and hope for the best */
--            fprintf(stderr, ssl_err_msg);
-+            fprintf(stderr, "%s",  ssl_err_msg);
-         }
-     }
- }