[packages] ipset: fix compilations against Linux v3.3 and newer (ipv6_addr_copy(...
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 20 Apr 2012 17:20:04 +0000 (17:20 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 20 Apr 2012 17:20:04 +0000 (17:20 +0000)
SVN-Revision: 31383

net/ipset/Makefile
net/ipset/patches/200-remove-ipv6_addr_copy.patch [new file with mode: 0644]

index 70901121c1fc34f68f421cf49f973efa00f64dea..c214be673f996c8961cb48881c4fbb79a50b5724 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ipset
 PKG_VERSION:=6.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://ipset.netfilter.org
diff --git a/net/ipset/patches/200-remove-ipv6_addr_copy.patch b/net/ipset/patches/200-remove-ipv6_addr_copy.patch
new file mode 100644 (file)
index 0000000..82a680f
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/kernel/net/netfilter/ipset/ip_set_hash_ip.c
++++ b/kernel/net/netfilter/ipset/ip_set_hash_ip.c
+@@ -241,7 +241,7 @@ hash_ip6_data_isnull(const struct hash_i
+ static inline void
+ hash_ip6_data_copy(struct hash_ip6_elem *dst, const struct hash_ip6_elem *src)
+ {
+-      ipv6_addr_copy(&dst->ip.in6, &src->ip.in6);
++      dst->ip.in6 = src->ip.in6;
+ }
+ static inline void
+--- a/kernel/net/netfilter/ipset/ip_set_hash_net.c
++++ b/kernel/net/netfilter/ipset/ip_set_hash_net.c
+@@ -295,7 +295,7 @@ static inline void
+ hash_net6_data_copy(struct hash_net6_elem *dst,
+                   const struct hash_net6_elem *src)
+ {
+-      ipv6_addr_copy(&dst->ip.in6, &src->ip.in6);
++      dst->ip.in6 = src->ip.in6;
+       dst->cidr = src->cidr;
+       dst->nomatch = src->nomatch;
+ }