move MyLoader partition parser into generic files, will be used on ar71xx
authorGabor Juhos <juhosg@openwrt.org>
Mon, 17 Nov 2008 10:14:58 +0000 (10:14 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 17 Nov 2008 10:14:58 +0000 (10:14 +0000)
SVN-Revision: 13256

target/linux/adm5120/files/drivers/mtd/myloader.c [deleted file]
target/linux/adm5120/patches-2.6.26/100-mtd_myloder_partition_parser.patch [deleted file]
target/linux/adm5120/patches-2.6.27/100-mtd_myloder_partition_parser.patch [deleted file]
target/linux/generic-2.6/config-2.6.26
target/linux/generic-2.6/config-2.6.27
target/linux/generic-2.6/files/drivers/mtd/myloader.c [new file with mode: 0644]
target/linux/generic-2.6/patches-2.6.26/081-mtd_myloader_partition_parser.patch [new file with mode: 0644]
target/linux/generic-2.6/patches-2.6.27/081-mtd_myloader_partition_parser.patch [new file with mode: 0644]

diff --git a/target/linux/adm5120/files/drivers/mtd/myloader.c b/target/linux/adm5120/files/drivers/mtd/myloader.c
deleted file mode 100644 (file)
index 60ebe22..0000000
+++ /dev/null
@@ -1,178 +0,0 @@
-/*
- *  Parse MyLoader-style flash partition tables and produce a Linux partition
- *  array to match.
- *
- *  Copyright (C) 2007-2008 Gabor Juhos <juhosg@openwrt.org>
- *
- *  This file was based on drivers/mtd/redboot.c
- *  Author: Red Hat, Inc. - David Woodhouse <dwmw2@cambridge.redhat.com>
- *
- *  This program is free software; you can redistribute it and/or modify it
- *  under the terms of the GNU General Public License version 2 as published
- *  by the Free Software Foundation.
- *
- */
-
-#include <linux/kernel.h>
-#include <linux/slab.h>
-#include <linux/init.h>
-#include <linux/vmalloc.h>
-#include <linux/mtd/mtd.h>
-#include <linux/mtd/partitions.h>
-#include <linux/byteorder/generic.h>
-#include <linux/myloader.h>
-
-#define BLOCK_LEN_MIN          0x10000
-#define PART_NAME_LEN          32
-
-struct part_data {
-       struct mylo_partition_table     tab;
-       char names[MYLO_MAX_PARTITIONS][PART_NAME_LEN];
-};
-
-int myloader_parse_partitions(struct mtd_info *master,
-                       struct mtd_partition **pparts,
-                       unsigned long origin)
-{
-       struct part_data *buf;
-       struct mylo_partition_table *tab;
-       struct mylo_partition *part;
-       struct mtd_partition *mtd_parts;
-       struct mtd_partition *mtd_part;
-       int num_parts;
-       int ret, i;
-       size_t retlen;
-       char *names;
-       unsigned long offset;
-       unsigned long blocklen;
-
-       buf = vmalloc(sizeof(*buf));
-       if (!buf) {
-               return -ENOMEM;
-               goto out;
-       }
-       tab = &buf->tab;
-
-       blocklen = master->erasesize;
-       if (blocklen < BLOCK_LEN_MIN)
-               blocklen = BLOCK_LEN_MIN;
-
-       offset = blocklen;
-
-       /* Find the partition table */
-       for (i = 0; i < 4; i++, offset += blocklen) {
-               printk(KERN_DEBUG "%s: searching for MyLoader partition table"
-                               " at offset 0x%lx\n", master->name, offset);
-
-               ret = master->read(master, offset, sizeof(*buf), &retlen,
-                                       (void *)buf);
-               if (ret)
-                       goto out_free_buf;
-
-               if (retlen != sizeof(*buf)) {
-                       ret = -EIO;
-                       goto out_free_buf;
-               }
-
-               /* Check for Partition Table magic number */
-               if (tab->magic == le32_to_cpu(MYLO_MAGIC_PARTITIONS))
-                       break;
-
-       }
-
-       if (tab->magic != le32_to_cpu(MYLO_MAGIC_PARTITIONS)) {
-               printk(KERN_DEBUG "%s: no MyLoader partition table found\n",
-                       master->name);
-               ret = 0;
-               goto out_free_buf;
-       }
-
-       /* The MyLoader and the Partition Table is always present */
-       num_parts = 2;
-
-       /* Detect number of used partitions */
-       for (i = 0; i < MYLO_MAX_PARTITIONS; i++) {
-               part = &tab->partitions[i];
-
-               if (le16_to_cpu(part->type) == PARTITION_TYPE_FREE)
-                       continue;
-
-               num_parts++;
-       }
-
-       mtd_parts = kzalloc((num_parts * sizeof(*mtd_part) +
-                               num_parts * PART_NAME_LEN), GFP_KERNEL);
-
-       if (!mtd_parts) {
-               ret = -ENOMEM;
-               goto out_free_buf;
-       }
-
-       mtd_part = mtd_parts;
-       names = (char *)&mtd_parts[num_parts];
-
-       strncpy(names, "myloader", PART_NAME_LEN);
-       mtd_part->name = names;
-       mtd_part->offset = 0;
-       mtd_part->size = offset;
-       mtd_part->mask_flags = MTD_WRITEABLE;
-       mtd_part++;
-       names += PART_NAME_LEN;
-
-       strncpy(names, "partition_table", PART_NAME_LEN);
-       mtd_part->name = names;
-       mtd_part->offset = offset;
-       mtd_part->size = blocklen;
-       mtd_part->mask_flags = MTD_WRITEABLE;
-       mtd_part++;
-       names += PART_NAME_LEN;
-
-       for (i = 0; i < MYLO_MAX_PARTITIONS; i++) {
-               part = &tab->partitions[i];
-
-               if (le16_to_cpu(part->type) == PARTITION_TYPE_FREE)
-                       continue;
-
-               if (buf->names[i][0])
-                       strncpy(names, buf->names[i], PART_NAME_LEN);
-               else
-                       snprintf(names, PART_NAME_LEN, "partition%d", i);
-
-               mtd_part->offset = le32_to_cpu(part->addr);
-               mtd_part->size = le32_to_cpu(part->size);
-               mtd_part->name = names;
-               mtd_part++;
-               names += PART_NAME_LEN;
-       }
-
-       *pparts = mtd_parts;
-       ret = num_parts;
-
- out_free_buf:
-       vfree(buf);
- out:
-       return ret;
-}
-
-static struct mtd_part_parser myloader_mtd_parser = {
-       .owner          = THIS_MODULE,
-       .parse_fn       = myloader_parse_partitions,
-       .name           = "MyLoader",
-};
-
-static int __init myloader_mtd_parser_init(void)
-{
-       return register_mtd_parser(&myloader_mtd_parser);
-}
-
-static void __exit myloader_mtd_parser_exit(void)
-{
-       deregister_mtd_parser(&myloader_mtd_parser);
-}
-
-module_init(myloader_mtd_parser_init);
-module_exit(myloader_mtd_parser_exit);
-
-MODULE_AUTHOR("Gabor Juhos <juhosg@openwrt.org>");
-MODULE_DESCRIPTION("Parsing code for MyLoader partition tables");
-MODULE_LICENSE("GPL v2");
diff --git a/target/linux/adm5120/patches-2.6.26/100-mtd_myloder_partition_parser.patch b/target/linux/adm5120/patches-2.6.26/100-mtd_myloder_partition_parser.patch
deleted file mode 100644 (file)
index 17cd986..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -174,6 +174,22 @@ config MTD_AR7_PARTS
-       ---help---
-         TI AR7 partitioning support
-+config MTD_MYLOADER_PARTS
-+      tristate "MyLoader partition parsing"
-+      depends on ADM5120 && MTD_PARTITIONS
-+      ---help---
-+        MyLoader is a bootloader which allows the user to define partitions
-+        in flash devices, by putting a table in the second erase block
-+        on the device, similar to a partition table. This table gives the 
-+        offsets and lengths of the user defined partitions.
-+
-+        If you need code which can detect and parse these tables, and
-+        register MTD 'partitions' corresponding to each image detected,
-+        enable this option.
-+
-+        You will still need the parsing functions to be called by the driver
-+        for your particular device. It won't happen automatically.
-+
- comment "User Modules And Translation Layers"
- config MTD_CHAR
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdli
- obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o
- obj-$(CONFIG_MTD_AR7_PARTS)   += ar7part.o
- obj-$(CONFIG_MTD_OF_PARTS)      += ofpart.o
-+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
- # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_CHAR)                += mtdchar.o
diff --git a/target/linux/adm5120/patches-2.6.27/100-mtd_myloder_partition_parser.patch b/target/linux/adm5120/patches-2.6.27/100-mtd_myloder_partition_parser.patch
deleted file mode 100644 (file)
index 90e2219..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -172,6 +172,22 @@ config MTD_AR7_PARTS
-       ---help---
-         TI AR7 partitioning support
-+config MTD_MYLOADER_PARTS
-+      tristate "MyLoader partition parsing"
-+      depends on ADM5120 && MTD_PARTITIONS
-+      ---help---
-+        MyLoader is a bootloader which allows the user to define partitions
-+        in flash devices, by putting a table in the second erase block
-+        on the device, similar to a partition table. This table gives the 
-+        offsets and lengths of the user defined partitions.
-+
-+        If you need code which can detect and parse these tables, and
-+        register MTD 'partitions' corresponding to each image detected,
-+        enable this option.
-+
-+        You will still need the parsing functions to be called by the driver
-+        for your particular device. It won't happen automatically.
-+
- comment "User Modules And Translation Layers"
- config MTD_CHAR
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdli
- obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o
- obj-$(CONFIG_MTD_AR7_PARTS)   += ar7part.o
- obj-$(CONFIG_MTD_OF_PARTS)      += ofpart.o
-+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
- # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_CHAR)                += mtdchar.o
index d46f154dbfaf0fde6da581ff8bf20a2b63dc8bc5..72ad1dfd667cf39ceaf9fce0e85af00db0993a6b 100644 (file)
@@ -802,6 +802,7 @@ CONFIG_MSDOS_PARTITION=y
 # CONFIG_MTD_DATAFLASH is not set
 # CONFIG_MTD_M25P80 is not set
 # CONFIG_MTD_INTEL_VR_NOR is not set
+# CONFIG_MTD_MYLOADER_PARTS is not set
 # CONFIG_MTD_NAND is not set
 # CONFIG_MTD_OOPS is not set
 # CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED is not set
index 8e6a5e419abdfb8710f8df8308c8e0933913c293..df3fe1339c39e3b1e93096d1a26f509bb231af06 100644 (file)
@@ -839,6 +839,7 @@ CONFIG_MSDOS_PARTITION=y
 # CONFIG_MTD_DOC2001PLUS is not set
 # CONFIG_MTD_INTEL_VR_NOR is not set
 # CONFIG_MTD_M25P80 is not set
+# CONFIG_MTD_MYLOADER_PARTS is not set
 # CONFIG_MTD_NAND is not set
 # CONFIG_MTD_OOPS is not set
 # CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED is not set
diff --git a/target/linux/generic-2.6/files/drivers/mtd/myloader.c b/target/linux/generic-2.6/files/drivers/mtd/myloader.c
new file mode 100644 (file)
index 0000000..60ebe22
--- /dev/null
@@ -0,0 +1,178 @@
+/*
+ *  Parse MyLoader-style flash partition tables and produce a Linux partition
+ *  array to match.
+ *
+ *  Copyright (C) 2007-2008 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This file was based on drivers/mtd/redboot.c
+ *  Author: Red Hat, Inc. - David Woodhouse <dwmw2@cambridge.redhat.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ *
+ */
+
+#include <linux/kernel.h>
+#include <linux/slab.h>
+#include <linux/init.h>
+#include <linux/vmalloc.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/byteorder/generic.h>
+#include <linux/myloader.h>
+
+#define BLOCK_LEN_MIN          0x10000
+#define PART_NAME_LEN          32
+
+struct part_data {
+       struct mylo_partition_table     tab;
+       char names[MYLO_MAX_PARTITIONS][PART_NAME_LEN];
+};
+
+int myloader_parse_partitions(struct mtd_info *master,
+                       struct mtd_partition **pparts,
+                       unsigned long origin)
+{
+       struct part_data *buf;
+       struct mylo_partition_table *tab;
+       struct mylo_partition *part;
+       struct mtd_partition *mtd_parts;
+       struct mtd_partition *mtd_part;
+       int num_parts;
+       int ret, i;
+       size_t retlen;
+       char *names;
+       unsigned long offset;
+       unsigned long blocklen;
+
+       buf = vmalloc(sizeof(*buf));
+       if (!buf) {
+               return -ENOMEM;
+               goto out;
+       }
+       tab = &buf->tab;
+
+       blocklen = master->erasesize;
+       if (blocklen < BLOCK_LEN_MIN)
+               blocklen = BLOCK_LEN_MIN;
+
+       offset = blocklen;
+
+       /* Find the partition table */
+       for (i = 0; i < 4; i++, offset += blocklen) {
+               printk(KERN_DEBUG "%s: searching for MyLoader partition table"
+                               " at offset 0x%lx\n", master->name, offset);
+
+               ret = master->read(master, offset, sizeof(*buf), &retlen,
+                                       (void *)buf);
+               if (ret)
+                       goto out_free_buf;
+
+               if (retlen != sizeof(*buf)) {
+                       ret = -EIO;
+                       goto out_free_buf;
+               }
+
+               /* Check for Partition Table magic number */
+               if (tab->magic == le32_to_cpu(MYLO_MAGIC_PARTITIONS))
+                       break;
+
+       }
+
+       if (tab->magic != le32_to_cpu(MYLO_MAGIC_PARTITIONS)) {
+               printk(KERN_DEBUG "%s: no MyLoader partition table found\n",
+                       master->name);
+               ret = 0;
+               goto out_free_buf;
+       }
+
+       /* The MyLoader and the Partition Table is always present */
+       num_parts = 2;
+
+       /* Detect number of used partitions */
+       for (i = 0; i < MYLO_MAX_PARTITIONS; i++) {
+               part = &tab->partitions[i];
+
+               if (le16_to_cpu(part->type) == PARTITION_TYPE_FREE)
+                       continue;
+
+               num_parts++;
+       }
+
+       mtd_parts = kzalloc((num_parts * sizeof(*mtd_part) +
+                               num_parts * PART_NAME_LEN), GFP_KERNEL);
+
+       if (!mtd_parts) {
+               ret = -ENOMEM;
+               goto out_free_buf;
+       }
+
+       mtd_part = mtd_parts;
+       names = (char *)&mtd_parts[num_parts];
+
+       strncpy(names, "myloader", PART_NAME_LEN);
+       mtd_part->name = names;
+       mtd_part->offset = 0;
+       mtd_part->size = offset;
+       mtd_part->mask_flags = MTD_WRITEABLE;
+       mtd_part++;
+       names += PART_NAME_LEN;
+
+       strncpy(names, "partition_table", PART_NAME_LEN);
+       mtd_part->name = names;
+       mtd_part->offset = offset;
+       mtd_part->size = blocklen;
+       mtd_part->mask_flags = MTD_WRITEABLE;
+       mtd_part++;
+       names += PART_NAME_LEN;
+
+       for (i = 0; i < MYLO_MAX_PARTITIONS; i++) {
+               part = &tab->partitions[i];
+
+               if (le16_to_cpu(part->type) == PARTITION_TYPE_FREE)
+                       continue;
+
+               if (buf->names[i][0])
+                       strncpy(names, buf->names[i], PART_NAME_LEN);
+               else
+                       snprintf(names, PART_NAME_LEN, "partition%d", i);
+
+               mtd_part->offset = le32_to_cpu(part->addr);
+               mtd_part->size = le32_to_cpu(part->size);
+               mtd_part->name = names;
+               mtd_part++;
+               names += PART_NAME_LEN;
+       }
+
+       *pparts = mtd_parts;
+       ret = num_parts;
+
+ out_free_buf:
+       vfree(buf);
+ out:
+       return ret;
+}
+
+static struct mtd_part_parser myloader_mtd_parser = {
+       .owner          = THIS_MODULE,
+       .parse_fn       = myloader_parse_partitions,
+       .name           = "MyLoader",
+};
+
+static int __init myloader_mtd_parser_init(void)
+{
+       return register_mtd_parser(&myloader_mtd_parser);
+}
+
+static void __exit myloader_mtd_parser_exit(void)
+{
+       deregister_mtd_parser(&myloader_mtd_parser);
+}
+
+module_init(myloader_mtd_parser_init);
+module_exit(myloader_mtd_parser_exit);
+
+MODULE_AUTHOR("Gabor Juhos <juhosg@openwrt.org>");
+MODULE_DESCRIPTION("Parsing code for MyLoader partition tables");
+MODULE_LICENSE("GPL v2");
diff --git a/target/linux/generic-2.6/patches-2.6.26/081-mtd_myloader_partition_parser.patch b/target/linux/generic-2.6/patches-2.6.26/081-mtd_myloader_partition_parser.patch
new file mode 100644 (file)
index 0000000..17cd986
--- /dev/null
@@ -0,0 +1,35 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -174,6 +174,22 @@ config MTD_AR7_PARTS
+       ---help---
+         TI AR7 partitioning support
++config MTD_MYLOADER_PARTS
++      tristate "MyLoader partition parsing"
++      depends on ADM5120 && MTD_PARTITIONS
++      ---help---
++        MyLoader is a bootloader which allows the user to define partitions
++        in flash devices, by putting a table in the second erase block
++        on the device, similar to a partition table. This table gives the 
++        offsets and lengths of the user defined partitions.
++
++        If you need code which can detect and parse these tables, and
++        register MTD 'partitions' corresponding to each image detected,
++        enable this option.
++
++        You will still need the parsing functions to be called by the driver
++        for your particular device. It won't happen automatically.
++
+ comment "User Modules And Translation Layers"
+ config MTD_CHAR
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdli
+ obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o
+ obj-$(CONFIG_MTD_AR7_PARTS)   += ar7part.o
+ obj-$(CONFIG_MTD_OF_PARTS)      += ofpart.o
++obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR)                += mtdchar.o
diff --git a/target/linux/generic-2.6/patches-2.6.27/081-mtd_myloader_partition_parser.patch b/target/linux/generic-2.6/patches-2.6.27/081-mtd_myloader_partition_parser.patch
new file mode 100644 (file)
index 0000000..90e2219
--- /dev/null
@@ -0,0 +1,35 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -172,6 +172,22 @@ config MTD_AR7_PARTS
+       ---help---
+         TI AR7 partitioning support
++config MTD_MYLOADER_PARTS
++      tristate "MyLoader partition parsing"
++      depends on ADM5120 && MTD_PARTITIONS
++      ---help---
++        MyLoader is a bootloader which allows the user to define partitions
++        in flash devices, by putting a table in the second erase block
++        on the device, similar to a partition table. This table gives the 
++        offsets and lengths of the user defined partitions.
++
++        If you need code which can detect and parse these tables, and
++        register MTD 'partitions' corresponding to each image detected,
++        enable this option.
++
++        You will still need the parsing functions to be called by the driver
++        for your particular device. It won't happen automatically.
++
+ comment "User Modules And Translation Layers"
+ config MTD_CHAR
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdli
+ obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o
+ obj-$(CONFIG_MTD_AR7_PARTS)   += ar7part.o
+ obj-$(CONFIG_MTD_OF_PARTS)      += ofpart.o
++obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR)                += mtdchar.o