bison: new package
authorW. Michael Petullo <mike@flyn.org>
Wed, 13 Apr 2022 19:40:22 +0000 (14:40 -0500)
committerNick Hainke <vincent@systemli.org>
Thu, 14 Apr 2022 04:41:49 +0000 (06:41 +0200)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
devel/bison/Makefile [new file with mode: 0644]

diff --git a/devel/bison/Makefile b/devel/bison/Makefile
new file mode 100644 (file)
index 0000000..94183f9
--- /dev/null
@@ -0,0 +1,43 @@
+# SPDX-Identifier-License: GPL-2.0-only
+#
+# Copyright (C) 2022 W. Michael Petullo <mike@flyn.org>
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bison
+PKG_VERSION:=3.8.2
+PKG_RELEASE:=$(AUTORELEASE)
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_HASH:=9bba0214ccf7f1079c5d59210045227bcf619519840ebfa80cd3849cff5a5bf2
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=COPYING
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bison
+  SECTION:=devel
+  CATEGORY:=Development
+  TITLE:=bison
+  URL:=http://www.gnu.org/software/bison/
+endef
+
+define Package/bison/description
+  Bison is a general-purpose parser generator
+endef
+
+CONFIGURE_ARGS += --enable-threads=posix --disable-nls
+
+define Package/bison/install
+       $(INSTALL_DIR) $(1)/usr/bin/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/bin/bison \
+               $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,bison))