libtalloc: update to 2.3.4
authorRosen Penev <rosenp@gmail.com>
Sun, 6 Nov 2022 20:40:35 +0000 (12:40 -0800)
committerRosen Penev <rosenp@gmail.com>
Tue, 8 Nov 2022 01:30:21 +0000 (17:30 -0800)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libtalloc/Makefile
libs/libtalloc/patches/100-Remove_libbsd_dependency_check.patch
libs/libtalloc/patches/101_wafsamba-replace-echo-n-with-printf.patch [deleted file]

index 71173504a7191c7437303a8103e37c6a8f362aa3..8972fa4c59fc9ac4bb8a53e949de105652252787 100644 (file)
@@ -6,13 +6,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=talloc
-PKG_VERSION:=2.3.1
+PKG_VERSION:=2.3.4
 MAJOR_VERSION:=2
-PKG_RELEASE:=4
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.samba.org/ftp/talloc
-PKG_HASH:=ef4822d2fdafd2be8e0cabc3ec3c806ae29b8268e932c5e9a4cd5585f37f9f77
+PKG_HASH:=179f9ebe265e67e4ab2c26cad2b7de4b6a77c6c212f966903382869f06be6505
 
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
 PKG_LICENSE:=LGPL-3.0-or-later
@@ -59,6 +59,7 @@ define Build/Configure
                        \nChecking uname version type: \"$(LINUX_UNAME_VERSION)\" \
                \n" ; \
                $(CONFIGURE_VARS) \
+               PYTHONHASHSEED=1 \
                ./buildtools/bin/waf configure \
                        --prefix=/usr \
                        --sysconfdir=/etc \
index 4fe2c6630187242c0fa3821b96f449de40c354b2..3478c58780d658f8efcc9c49e32a69fb62d8bfb7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/replace/wscript
 +++ b/lib/replace/wscript
-@@ -416,22 +416,13 @@ def configure(conf):
+@@ -429,22 +429,13 @@ def configure(conf):
  
      conf.CHECK_FUNCS('prctl dirname basename')
  
@@ -29,7 +29,7 @@
  
      conf.CHECK_CODE('''
                  struct ucred cred;
-@@ -808,9 +799,6 @@ def configure(conf):
+@@ -827,9 +818,6 @@ syscall(SYS_copy_file_range,0,NULL,0,NUL
  
      # look for a method of finding the list of network interfaces
      for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']:
@@ -39,7 +39,7 @@
          if conf.CHECK_CODE('''
                             #define %s 1
                             #define NO_CONFIG_H 1
-@@ -823,7 +811,7 @@ def configure(conf):
+@@ -842,7 +830,7 @@ syscall(SYS_copy_file_range,0,NULL,0,NUL
                             #include "tests/getifaddrs.c"
                             ''' % method,
                             method,
@@ -48,7 +48,7 @@
                             addmain=False,
                             execute=True):
              break
-@@ -871,7 +859,6 @@ def build(bld):
+@@ -890,7 +878,6 @@ def build(bld):
                  break
  
      extra_libs = ''
diff --git a/libs/libtalloc/patches/101_wafsamba-replace-echo-n-with-printf.patch b/libs/libtalloc/patches/101_wafsamba-replace-echo-n-with-printf.patch
deleted file mode 100644 (file)
index 9b8aca0..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-From: https://gitlab.com/samba-team/samba/-/merge_requests/2374/diffs?commit_id=90bb371863d5a44845f47ebbceeb60842b46eda7
-
-From 79b2f38c27c8df918d8260fe838f55bcf6d3eb73 Mon Sep 17 00:00:00 2001
-From: "Sergey V. Lobanov" <sergey@lobanov.in>
-Date: Thu, 10 Feb 2022 00:02:17 +0300
-Subject: [PATCH] wafsamba: replace 'echo -n' with printf
-
-This patch makes samba_cross.py compatible with old bash (e.g. 3.2)
-
-Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
----
- buildtools/wafsamba/samba_cross.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/buildtools/wafsamba/samba_cross.py
-+++ b/buildtools/wafsamba/samba_cross.py
-@@ -134,7 +134,7 @@ class cross_Popen(Utils.subprocess.Popen
-                 cross_answers_incomplete = True
-                 add_answer(ca_file, msg, ans)
-             (retcode, retstring) = ans
--            args = ['/bin/sh', '-c', "echo -n '%s'; exit %d" % (retstring, retcode)]
-+            args = ['/bin/sh', '-c', "printf '%s'; exit %d" % (retstring, retcode)]
-         real_Popen.__init__(*(obj, args), **kw)