[package] add haveged
authorFlorian Fainelli <florian@openwrt.org>
Mon, 2 Apr 2012 16:19:59 +0000 (16:19 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 2 Apr 2012 16:19:59 +0000 (16:19 +0000)
I've checked the haveged makefile now, it only relies on librt, so the
attached patch should have no issues under any platform.

Signed-off-by: Oliver Smith <olipro@8.c.9.b.0.7.4.0.1.0.0.2.ip6.arpa>
SVN-Revision: 31161

utils/haveged/Makefile [new file with mode: 0644]
utils/haveged/files/haveged.init [new file with mode: 0644]

diff --git a/utils/haveged/Makefile b/utils/haveged/Makefile
new file mode 100644 (file)
index 0000000..b963e4a
--- /dev/null
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 1 2012-01-12 03:50:18Z Olipro $ 
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=haveged
+PKG_VERSION:=1.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.issihosts.com/$(PKG_NAME)
+PKG_MD5SUM:=39a03d4b8a4225706f78dbef3f623b0e
+
+#ensure this is consistent with the dir in the tarball!!!
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/haveged
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Feeds the kernel entropy pool by timing CPU loops.
+  DEPENDS:=+librt
+  URL:=http://www.issihosts.com/haveged/
+endef
+
+define Package/haveged/install
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/haveged.init $(1)/etc/init.d/haveged
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/haveged $(1)/sbin/
+endef
+
+$(eval $(call BuildPackage,haveged))
diff --git a/utils/haveged/files/haveged.init b/utils/haveged/files/haveged.init
new file mode 100644 (file)
index 0000000..129d951
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2012 OpenWrt.org
+
+START=98
+
+HAVEGED_THRESHOLD=1024
+HAVEGED_DCACHE=32
+HAVEGED_ICACHE=32
+
+start() {
+       service_start /sbin/haveged -w $HAVEGED_THRESHOLD -d $HAVEGED_DCACHE -i $HAVEGED_ICACHE -v 1
+}
+
+stop() {
+       service_stop /sbin/haveged
+}