nginx: update to 1.24.0 and update headers-more module
authorChristian Marangi <ansuelsmth@gmail.com>
Thu, 20 Apr 2023 12:17:20 +0000 (14:17 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 27 Apr 2023 04:14:58 +0000 (06:14 +0200)
Update nginx to 1.24.0 and update headers-more module to fix compilation
error.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
net/nginx/Makefile
net/nginx/patches/nginx/201-ignore-invalid-options.patch

index 837383897b4c70f010e7e1a120c394c1b16188c1..4fc95b487f556cfc997a6d95533c27d73ad69011 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nginx
-PKG_VERSION:=1.21.3
-PKG_RELEASE:=4
+PKG_VERSION:=1.24.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://nginx.org/download/
-PKG_HASH:=14774aae0d151da350417efc4afda5cce5035056e71894836797e1f6e2d1175a
+PKG_HASH:=77a2541637b92a621e3ee76776c8b7b40cf6d707e69ba53a940283e30ff2f55d
 
 PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de> \
                                Ansuel Smith <ansuelsmth@gmail.com>
@@ -452,11 +452,11 @@ endef
 Package/nginx-all-module/prerm = $(Package/nginx-ssl/prerm)
 
 define Download/nginx-headers-more
-  VERSION:=a9f7c7e86cc7441d04e2f11f01c2e3a9c4b0301d
+  VERSION:=bea1be3bbf6af28f6aa8cf0c01c07ee1637e2bd0
   SUBDIR:=nginx-headers-more
   FILE:=headers-more-nginx-module-$$(VERSION).tar.xz
   URL:=https://github.com/openresty/headers-more-nginx-module.git
-  MIRROR_HASH:=ce0b9996ecb2cff790831644d6ab1adc087aa2771d77d3931c06246d11bc59fd
+  MIRROR_HASH:=3617bbf7a935208a1d8d5f86a8f9b770f6987e4d2b5663a9ab1b777217e3066b
   PROTO:=git
 endef
 
index d208bf5076c206da2dd2c58c75fba2a2896ad3e2..8ea567167a4180e27288a096f1e672dc3cd7c88e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/auto/options
 +++ b/auto/options
-@@ -400,8 +400,7 @@ $0: warning: the \"--with-sha1-asm\" opt
+@@ -402,8 +402,7 @@ $0: warning: the \"--with-sha1-asm\" opt
          --test-build-solaris-sendfilev)  NGX_TEST_BUILD_SOLARIS_SENDFILEV=YES ;;
  
          *)