oxnas/kd20: use gpio-beeper
authorJohn Crispin <john@openwrt.org>
Tue, 2 Dec 2014 15:25:09 +0000 (15:25 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 2 Dec 2014 15:25:09 +0000 (15:25 +0000)
gpio-beeper module was added to the kernel recently.
Make use of it to drive the piezoelectric buzzer of the kd20.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 43496

target/linux/oxnas/files/arch/arm/boot/dts/ox820-kd20.dts
target/linux/oxnas/profiles/100-Generic.mk

index e7ee5871c423382386721c5f117f7dbb789f900d..9f52f43f80c9ed8d00319361d2f44e713f412a3f 100644 (file)
                        label = "kd20:blue:usb";
                        gpios = <&GPIOB 8 0>;
                };
-               buzzer {
-                       label = "kd20:buzzer";
-                       gpios = <&GPIOB 11 0>;
-               };
+       };
+
+       beeper: beeper {
+               compatible = "gpio-beeper";
+               gpios = <&GPIOB 11 0>;
        };
 
        gpio-fan {
index 734b12376ae913b5cef99ba29c95a07c6af97c79..d5ec97d44e7c16a17d72c096bd99f968ffb00795 100644 (file)
@@ -40,7 +40,7 @@ endef
 define Profile/KD20
   NAME:=Shuttle KD20
   PACKAGES:= \
-       uboot-envtools kmod-usb2-oxnas kmod-usb3 kmod-rtc-pcf8563
+       uboot-envtools kmod-usb2-oxnas kmod-usb3 kmod-rtc-pcf8563 kmod-gpio-beeper
 endef
 
 define Profile/KD20/Description