[packages] darkstat: fix build failure
authorNicolas Thill <nico@openwrt.org>
Fri, 14 Oct 2011 10:07:50 +0000 (10:07 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 14 Oct 2011 10:07:50 +0000 (10:07 +0000)
conv.c: In function 'strtonum':
conv.c:487: error: 'LLONG_MIN' undeclared (first use in this function)

SVN-Revision: 28449

net/darkstat/Makefile

index 62ab82e27772d8eb8eb1d0326c66e2884feb9a70..99eb1370824df8a2edd035b2da9fc6e10a830d07 100644 (file)
@@ -41,6 +41,8 @@ CONFIGURE_ARGS += \
        --disable-debug \
        --with-chroot-dir=/var/empty
 
+TARGET_CFLAGS += -std=gnu99
+
 define Build/Compile
        $(HOSTCC) $(PKG_BUILD_DIR)/static/c-ify.c \
                -o $(PKG_BUILD_DIR)/c-ify