postgresql: clean package to fix duplicate files issue
authorDaniel Golle <daniel@makrotopia.org>
Tue, 27 Sep 2016 18:41:53 +0000 (20:41 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 27 Sep 2016 19:08:12 +0000 (21:08 +0200)
Both postgresql-server and postgresql-cli install /usr/bin/psql which
thus creates a conflict when installing both packages.
Fix this by removing duplicate and useless binaries from the
postgresql-server package.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
libs/postgresql/Makefile

index a1564dc3dfc7b25f4e8651c24da257b75d533167..3423ad6002fc6a91985ec9804c984b686a852c43 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
 PKG_VERSION:=9.5.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=PostgreSQL
 
@@ -68,6 +68,36 @@ define Package/pgsql-server/description
 PostgreSQL databases Server.
 endef
 
+PGSQL_SERVER_BIN := \
+       clusterdb               \
+       createdb                \
+       createlang              \
+       createuser              \
+       dropdb                  \
+       droplang                \
+       dropuser                \
+       initdb                  \
+       pg_archivecleanup       \
+       pg_basebackup           \
+       pgbench                 \
+       pg_controldata          \
+       pg_ctl                  \
+       pg_dump                 \
+       pg_dumpall              \
+       pg_isready              \
+       pg_receivexlog          \
+       pg_recvlogical          \
+       pg_resetxlog            \
+       pg_restore              \
+       pg_rewind               \
+       pg_test_fsync           \
+       pg_test_timing          \
+       pg_upgrade              \
+       pg_xlogdump             \
+       postgres                \
+       reindexdb               \
+       vacuumdb
+
 PGSQL_CONFIG_VARS:= \
        pgac_cv_snprintf_long_long_int_format="%lld" \
        pgac_cv_snprintf_size_t_support=yes
@@ -158,7 +188,7 @@ endef
 
 define Package/pgsql-server/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
+       $(INSTALL_BIN) $(foreach bin,$(PGSQL_SERVER_BIN),$(PKG_INSTALL_DIR)/usr/bin/$(bin)) $(1)/usr/bin
        ln -sf postgres $(1)/usr/bin/postmaster
 
        $(INSTALL_DIR) $(1)/usr/share/postgresql
@@ -179,10 +209,6 @@ define Package/pgsql-server/install
        $(INSTALL_BIN) ./files/postgresql.init $(1)/etc/init.d/postgresql
 endef
 
-define Package/pgsql-server/conffiles
-/etc/config/postgresql
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_DIR) $(1)/usr/include