unixodbc: use 'install' when copying host binaries 16326/head
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Wed, 11 Aug 2021 14:04:50 +0000 (11:04 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Wed, 11 Aug 2021 19:59:20 +0000 (16:59 -0300)
'cp' fails with a text file busy error if it tries to overwrite an
executable file that is running.  'install' unlinks the file first, so
it will not cause the problem.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
libs/unixodbc/Makefile

index 603b93379000e8e7ce4f5d084ec1e51b0aeb1c66..f2600432f5bf90eb4e05310352f666b7b3d42b37 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=unixodbc
 PKG_VERSION:=2.3.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=unixODBC-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.unixodbc.org
@@ -152,7 +152,7 @@ endef
 
 define Host/Install
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
-       $(CP) $(HOST_BUILD_DIR)/exe/odbc_config $(STAGING_DIR_HOST)/bin
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/exe/odbc_config $(STAGING_DIR_HOST)/bin
 endef
 
 $(eval $(call BuildPackage,unixodbc))