zerotier: update to 1.8.9
authorMoritz Warning <moritzwarning@web.de>
Sat, 30 Apr 2022 15:38:25 +0000 (17:38 +0200)
committerRosen Penev <rosenp@gmail.com>
Sat, 30 Apr 2022 18:55:46 +0000 (11:55 -0700)
Replace patch with Makefile options
to disable Rust components that
cannot be build with OpenWrt.

Signed-off-by: Moritz Warning <moritzwarning@web.de>
net/zerotier/Makefile
net/zerotier/patches/0001-fix-makefile.patch
net/zerotier/patches/0002-fix-compilation-for-arm_cortex-a7-neon.patch
net/zerotier/patches/0003-do-not-use-zt-SSO-and-OIDC.patch [deleted file]

index ca3222cf2126a17b36db36587d1fa2496e44c4d0..76e5f5772e03635db0d8263df14164640ad138a0 100644 (file)
@@ -6,12 +6,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zerotier
-PKG_VERSION:=1.8.8
+PKG_VERSION:=1.8.9
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=324799e10c04ccac43c67e733eacabe29d2cb3d2eb9b782f11b86c43ad714e3b
+PKG_HASH:=78fc0dda08d022b4fff9b88449d21a62016452304e930d4ee8393fe2930e65a8
 PKG_BUILD_DIR:=$(BUILD_DIR)/ZeroTierOne-$(PKG_VERSION)
 
 PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
@@ -45,6 +45,8 @@ MAKE_FLAGS += ZT_DEBUG=1
 endif
 
 MAKE_FLAGS += \
+       ZT_EMBEDDED=1 \
+       ZT_SSO_SUPPORTED=0 \
        DEFS="" \
        OSTYPE="Linux" \
 
index 2bc1aae8f262b2e21941ed1c948d1504ee86feb6..493cd6c4da9d74a938604ffee41621be5a54962c 100644 (file)
@@ -1,11 +1,11 @@
-From 4965b6d10b2f51f4b30a8c0a8f3a64cf48dea635 Mon Sep 17 00:00:00 2001
+From 2a867d408c7488a273022652c55e1b31545eba4c Mon Sep 17 00:00:00 2001
 From: Moritz Warning <moritzwarning@web.de>
 Date: Tue, 8 Mar 2022 19:09:47 +0100
 Subject: [PATCH 1/3] fix makefile
 
 ---
- make-linux.mk | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
+ make-linux.mk | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
 
 --- a/make-linux.mk
 +++ b/make-linux.mk
@@ -44,7 +44,7 @@ Subject: [PATCH 1/3] fix makefile
        RUSTFLAGS=--release
  endif
  
-@@ -300,7 +300,7 @@ ifeq ($(ZT_CONTROLLER),1)
+@@ -310,7 +310,7 @@ ifeq ($(ZT_CONTROLLER),1)
  endif
  
  # ARM32 hell -- use conservative CFLAGS
index 150129ab7a6753db9c3040838c83b73ff5de4f85..b45b916b2235df2eab06472bf3d1a49630aaf872 100644 (file)
@@ -1,4 +1,4 @@
-From 8c24328d41a3a25db3b3d73baf86ed2c71160774 Mon Sep 17 00:00:00 2001
+From 1f03e3ddf714063da645cf62d9df08cbcb3ddfb3 Mon Sep 17 00:00:00 2001
 From: Moritz Warning <moritzwarning@web.de>
 Date: Mon, 30 Nov 2020 12:25:42 +0100
 Subject: [PATCH 2/3] fix compilation for arm_cortex-a7+neon
@@ -12,7 +12,7 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
 
 --- a/node/Constants.hpp
 +++ b/node/Constants.hpp
-@@ -118,7 +118,7 @@
+@@ -123,7 +123,7 @@
  #include <immintrin.h>
  #endif
  
diff --git a/net/zerotier/patches/0003-do-not-use-zt-SSO-and-OIDC.patch b/net/zerotier/patches/0003-do-not-use-zt-SSO-and-OIDC.patch
deleted file mode 100644 (file)
index 297f4e7..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From 826718bdbbd42fcf56bdb45dd9e71af10299cfa3 Mon Sep 17 00:00:00 2001
-From: Oskari Rauta <oskari.rauta@gmail.com>
-Date: Sun, 13 Mar 2022 10:06:08 +0100
-Subject: [PATCH 3/3] do not use zt SSO and OIDC
-
-These features need Rust/Cargo support
-in the build system. OpenWrt does not
-have that yet.
----
- make-linux.mk      | 4 ++++
- node/Constants.hpp | 3 +++
- 2 files changed, 7 insertions(+)
-
---- a/make-linux.mk
-+++ b/make-linux.mk
-@@ -268,6 +268,10 @@ ifeq ($(ZT_IA32),1)
- endif
- ifeq ($(ZT_SSO_SUPPORTED), 1)
-+      ZT_SSO_SUPPORTED=0
-+endif
-+
-+ifeq ($(ZT_SSO_SUPPORTED), 1)
-       ifeq ($(ZT_DEBUG),1)
-               LDLIBS+=zeroidc/target/debug/libzeroidc.a -ldl -lssl -lcrypto
-       else
---- a/node/Constants.hpp
-+++ b/node/Constants.hpp
-@@ -72,6 +72,9 @@
- #include <machine/endian.h>
- #endif
-+#undef OIDC_SUPPORTED
-+#define OIDC_SUPPORTED 0
-+
- #if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__)
- #define OIDC_SUPPORTED 0
- #ifndef __UNIX_LIKE__