glib2: revert intl change
authorRosen Penev <rosenp@gmail.com>
Fri, 31 Jul 2020 21:55:07 +0000 (14:55 -0700)
committerRosen Penev <rosenp@gmail.com>
Fri, 31 Jul 2020 22:11:54 +0000 (15:11 -0700)
This was causing massive buildbot failure.

The intent was to fix uClibc-ng and CONFIG_BUILD_NLS, but that ended up
breaking everything.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/glib2/Makefile
libs/glib2/patches/005-intl-fix.patch [deleted file]

index c7ab408eda7ae871c81e8e1cac8cc9c372195ae9..1b5148877d6e65eead32fa6e5a3bd4ce421cf8d8 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glib2
 PKG_VERSION:=2.65.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNOME/glib/2.65
@@ -43,9 +43,9 @@ define Package/glib2/description
   The GLib library of C routines
 endef
 
-HOST_LDFLAGS += -Wl,-rpath=$(STAGING_DIR_HOSTPKG)/lib
+HOST_LDFLAGS += -liconv -Wl,-rpath,$(STAGING_DIR_HOSTPKG)/lib
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_LDFLAGS += -Wl,--gc-sections -liconv
 
 COMP_ARGS= \
        -Diconv=external \
diff --git a/libs/glib2/patches/005-intl-fix.patch b/libs/glib2/patches/005-intl-fix.patch
deleted file mode 100644 (file)
index b765718..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -1955,7 +1955,7 @@ endif
- # FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
- # implementations. This could be extended if issues are found in some platforms.
- libintl_deps = []
--if cc.has_function('ngettext')
-+if false
-   have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
- else
-   # First just find the bare library.