kernel: bump 4.14 to 4.14.105
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 6 Mar 2019 15:59:52 +0000 (16:59 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 8 Mar 2019 15:56:11 +0000 (16:56 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/oxnas/patches-4.14/800-oxnas-ehci.patch
target/linux/sunxi/patches-4.14/002-net-stmmac-dwmac-sun8i-Handle-integrated-external-MD.patch
target/linux/sunxi/patches-4.14/003-net-stmmac-sun8i-Restore-the-compatibles.patch
target/linux/sunxi/patches-4.14/004-net-stmmac-dwmac-sun8i-fix-allwinner-leds-active-low.patch

index d62af62d77dd20bc2985e2eef108ded4d7e0dae3..228f4301520bbb88e68ff4e8197d57294607a810 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .162
-LINUX_VERSION-4.14 = .104
+LINUX_VERSION-4.14 = .105
 
 LINUX_KERNEL_HASH-4.9.162 = b946f44edcc4e1b1ccf51ce17dd8f494556555b31b0663bbaabfad99100dacd5
-LINUX_KERNEL_HASH-4.14.104 = dd430e3e65138da5799b5ff7353e1a9c72f2f9dc957ac53d2aea3dd8ca7be067
+LINUX_KERNEL_HASH-4.14.105 = 398bdb98b4e4d0ad0e60f4fa530f3f8451ef8dafdf512b7754aa29953263f6e9
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 69db38ed19284f15cc17c914a747db3a026fe6d5..264a09e68b2c817747086f35844f8f9739b9aedc 100644 (file)
@@ -51,7 +51,7 @@
                        #size-cells = <1>;
 --- a/arch/arm/boot/dts/ox820-cloudengines-pogoplug-series-3.dts
 +++ b/arch/arm/boot/dts/ox820-cloudengines-pogoplug-series-3.dts
-@@ -106,6 +106,10 @@
+@@ -102,6 +102,10 @@
        };
  };
  
index 8e0527f3d88019f382118cae98892e93666546a2..6cde0e29bca466d27afa9fa55d9e88ad7b98ce51 100644 (file)
@@ -115,7 +115,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
  /* H3/A64 specific bits */
  #define SYSCON_RMII_EN                BIT(13) /* 1: enable RMII (overrides EPIT) */
-@@ -634,6 +640,159 @@ static int sun8i_dwmac_reset(struct stmm
+@@ -635,6 +641,159 @@ static int sun8i_dwmac_reset(struct stmm
        return 0;
  }
  
@@ -275,7 +275,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static int sun8i_dwmac_set_syscon(struct stmmac_priv *priv)
  {
        struct sunxi_priv_data *gmac = priv->plat->bsp_priv;
-@@ -648,35 +807,25 @@ static int sun8i_dwmac_set_syscon(struct
+@@ -649,35 +808,25 @@ static int sun8i_dwmac_set_syscon(struct
                         "Current syscon value is not the default %x (expect %x)\n",
                         val, reg);
  
@@ -329,7 +329,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        }
  
        if (!of_property_read_u32(node, "allwinner,tx-delay-ps", &val)) {
-@@ -746,81 +895,21 @@ static void sun8i_dwmac_unset_syscon(str
+@@ -747,81 +896,21 @@ static void sun8i_dwmac_unset_syscon(str
        regmap_write(gmac->regmap, SYSCON_EMAC_REG, reg);
  }
  
@@ -420,7 +420,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        clk_disable_unprepare(gmac->tx_clk);
  
-@@ -849,7 +938,7 @@ static struct mac_device_info *sun8i_dwm
+@@ -850,7 +939,7 @@ static struct mac_device_info *sun8i_dwm
        if (!mac)
                return NULL;
  
@@ -429,7 +429,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        if (ret)
                return NULL;
  
-@@ -889,6 +978,8 @@ static int sun8i_dwmac_probe(struct plat
+@@ -890,6 +979,8 @@ static int sun8i_dwmac_probe(struct plat
        struct sunxi_priv_data *gmac;
        struct device *dev = &pdev->dev;
        int ret;
@@ -438,7 +438,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        ret = stmmac_get_platform_resources(pdev, &stmmac_res);
        if (ret)
-@@ -932,29 +1023,6 @@ static int sun8i_dwmac_probe(struct plat
+@@ -933,29 +1024,6 @@ static int sun8i_dwmac_probe(struct plat
        }
  
        plat_dat->interface = of_get_phy_mode(dev->of_node);
@@ -468,7 +468,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        /* platform data specifying hardware features and callbacks.
         * hardware features were copied from Allwinner drivers.
-@@ -973,9 +1041,34 @@ static int sun8i_dwmac_probe(struct plat
+@@ -974,9 +1042,34 @@ static int sun8i_dwmac_probe(struct plat
  
        ret = stmmac_dvr_probe(&pdev->dev, plat_dat, &stmmac_res);
        if (ret)
index 2f435850535577ce25f1da947cb5a1e19aebcf52..98898fb468f51e3f7ff41552a18f127bfc20890d 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/ethernet/stmicro/stmmac/dwmac-sun8i.c
 +++ b/drivers/net/ethernet/stmicro/stmmac/dwmac-sun8i.c
-@@ -1072,6 +1072,14 @@ return ret;
+@@ -1073,6 +1073,14 @@ return ret;
  }
  
  static const struct of_device_id sun8i_dwmac_match[] = {
index b8b5b53b3f7a991bd135457b4b8e9515393ecd94..1bd5e16c1642a1559df13e1a102de7d61ce470ed 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/ethernet/stmicro/stmmac/dwmac-sun8i.c
 +++ b/drivers/net/ethernet/stmicro/stmmac/dwmac-sun8i.c
-@@ -808,8 +808,7 @@ static int sun8i_dwmac_set_syscon(struct
+@@ -809,8 +809,7 @@ static int sun8i_dwmac_set_syscon(struct
                         val, reg);
  
        if (gmac->variant->soc_has_internal_phy) {