diffutils: add from old repo and update 301/head
authorRoger <rogerdammit@gmail.com>
Fri, 12 Sep 2014 00:33:36 +0000 (19:33 -0500)
committerRoger <rogerdammit@gmail.com>
Fri, 12 Sep 2014 23:41:39 +0000 (18:41 -0500)
Signed-off-by: Roger D <rogerdammit@gmail.com>
devel/diffutils/Makefile [new file with mode: 0644]

diff --git a/devel/diffutils/Makefile b/devel/diffutils/Makefile
new file mode 100644 (file)
index 0000000..33cdc12
--- /dev/null
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2008-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=diffutils
+PKG_VERSION:=3.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/diffutils
+PKG_MD5SUM:=99180208ec2a82ce71f55b0d7389f1b3
+PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
+PKG_LICENSE:=GPL-3.0
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/diffutils
+  SECTION:=devel
+  CATEGORY:=Development
+  DEPENDS:=+USE_EGLIBC:librt
+  TITLE:=diffutils
+  URL:=http://www.gnu.org/software/diffutils/
+endef
+
+define Package/diffutils/description
+  The Diffutils package contains programs that show the differences between
+  files or directories.
+endef
+
+CONFIGURE_VARS += \
+       ac_cv_func_mempcpy=n
+TARGET_CFLAGS += --std=c99
+
+define Package/diffutils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{sdiff,diff3,diff,cmp} $(1)/usr/bin/
+endef
+
+define Package/diffutils/preinst
+#!/bin/sh
+for x in sdiff diff3 diff cmp; do
+  [ -L "$${IPKG_INSTROOT}/usr/bin/$$x" ] && rm -f "$${IPKG_INSTROOT}/usr/bin/$$x"
+done
+exit 0
+endef
+
+define Package/diffutils/postrm
+#!/bin/sh
+for x in sdiff diff3 diff cmp; do
+  /bin/busybox $$x -h 2>&1 | grep -q BusyBox && ln -sf ../../bin/busybox /usr/bin/$$x
+done
+exit 0
+endef
+
+$(eval $(call BuildPackage,diffutils))