merge r13819 to 8.09 Add hostapd-mini to default images where applicable
authorAndy Boyett <agb@openwrt.org>
Tue, 13 Jan 2009 20:02:29 +0000 (20:02 +0000)
committerAndy Boyett <agb@openwrt.org>
Tue, 13 Jan 2009 20:02:29 +0000 (20:02 +0000)
SVN-Revision: 14026

16 files changed:
target/linux/adm5120/Makefile
target/linux/adm5120/router_le/profiles/Cellvision.mk
target/linux/adm5120/router_le/profiles/Edimax.mk
target/linux/ar71xx/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/au1000/profiles/InternetBox.mk
target/linux/au1000/profiles/MeshCube.mk
target/linux/brcm-2.4/profiles/120-Atheros.mk
target/linux/brcm47xx/Makefile
target/linux/brcm47xx/profiles/110-None.mk
target/linux/ifxmips/Makefile
target/linux/ixp4xx/generic/profiles/200-NSLU2.mk
target/linux/ixp4xx/generic/target.mk
target/linux/rb532/Makefile
target/linux/rdc/Makefile

index 4eebc6fba0f4385ccce81f29b69c07b416a83e34..3149d4f34ecf2bb4642dd3bb8c8919dc444b31bf 100644 (file)
@@ -15,11 +15,7 @@ INITRAMFS_EXTRA_FILES:=
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig
-DEFAULT_PACKAGES += \
-       kmod-input-core \
-       kmod-input-polldev \
-       kmod-input-gpio-buttons \
-       kmod-button-hotplug
+DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
 
 $(eval $(call BuildTarget))
index 9c8356a663408c95d237070f59a3cc1355af8829..9fa1e02330e12cc9d1a8ba0fadfd0050f7bf9bf2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007,2008 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,6 +8,7 @@
 define Profile/CAS630
        NAME:=Cellvision CAS-630 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS630/Description
@@ -17,6 +18,7 @@ endef
 define Profile/CAS630W
        NAME:=Cellvision CAS-630W IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS630W/Description
@@ -26,6 +28,7 @@ endef
 define Profile/CAS670
        NAME:=Cellvision CAS-670 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS670/Description
@@ -35,6 +38,7 @@ endef
 define Profile/CAS670W
        NAME:=Cellvision CAS-670W IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS670W/Description
@@ -44,6 +48,7 @@ endef
 define Profile/CAS700
        NAME:=Cellvision CAS-700 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS700/Description
@@ -53,6 +58,7 @@ endef
 define Profile/CAS700W
        NAME:=Cellvision CAS-700W IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS700W/Description
@@ -61,7 +67,7 @@ endef
 
 define Profile/CAS771
        NAME:=Cellvision CAS-771 IP camera (Experimental)
-       PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
+       PACKAGES:=-hostapd-mini kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
 endef
 
 define Profile/CAS771/Description
@@ -70,7 +76,7 @@ endef
 
 define Profile/CAS771W
        NAME:=Cellvision CAS-771W IP camera (Experimental)
-       PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500-pci
+       PACKAGES:=-hostapd-mini kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500-pci
 endef
 
 define Profile/CAS771W/Description
@@ -80,6 +86,7 @@ endef
 define Profile/CAS790
        NAME:=Cellvision CAS-790 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS790/Description
@@ -89,6 +96,7 @@ endef
 define Profile/CAS861
        NAME:=Cellvision CAS-861 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS861/Description
@@ -106,6 +114,7 @@ endef
 
 define Profile/NFS101U
        NAME:=Cellvision NFS-101U Network File Server (Experimental)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/NFS101U/Description
@@ -114,6 +123,7 @@ endef
 
 define Profile/NFS101WU
        NAME:=Cellvision NFS-101WU Network File Server (Experimental)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/NFS101WU/Description
index e4c427f570584451ebded5dcb2ef8dcedbb3c833..70b26534efcf499f5db8ef0ccfe1c63601d8ac44 100644 (file)
@@ -7,6 +7,7 @@
 
 define Profile/BR6104K
        NAME:=Edimax BR-6104K (Unofficial)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/BR6104K/Description
@@ -15,7 +16,7 @@ endef
 
 define Profile/BR6104KP
        NAME:=Edimax BR-6104KP (Unofficial)
-       PACKAGES:=kmod-usb-core kmod-usb-adm5120
+       PACKAGES:=-hostapd-mini kmod-usb-core kmod-usb-adm5120
 endef
 
 define Profile/BR6104KP/Description
@@ -24,6 +25,7 @@ endef
 
 define Profile/BR6104WG
        NAME:=Edimax BR-6104Wg (Unofficial, No WiFi)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/BR6104WG/Description
@@ -32,6 +34,7 @@ endef
 
 define Profile/BR6114WG
        NAME:=Edimax BR-6114WG (Unofficial, No WiFi)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/BR6114WG/Description
index 3f9d15f1cab3a9514cf05163b4f03fe12f7f69d3..d36835da0cb35a8a57f3ec0bcb7d36c35e83423d 100644 (file)
@@ -15,7 +15,7 @@ LINUX_VERSION:=2.6.26.5
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
 
 define Target/Description
        Build firmware images for Atheros AR71xx based boards
index e6290c58cab24ce81bdf2817eaadb8f83e4a608c..124d50d3c61471374bb412d8a7b6012d3a5e38b7 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,7 @@ LINUX_VERSION:=2.6.26.5
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi gpioctl
+DEFAULT_PACKAGES += hostapd-mini kmod-madwifi gpioctl
 
 define Target/Description
        Build firmware images for Atheros SoC boards
index 4db3a39dc8b955bb500f938002fac4cca8d8b81c..c8163bf5be156f5349435f6ad058e75f575c4d90 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,7 +14,7 @@ FEATURES:=jffs2 usb pci
 LINUX_VERSION:=2.6.25.17
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += yamonenv
+DEFAULT_PACKAGES += hostapd-mini yamonenv
 
 define Target/Description
        Build firmware for AMD Alchemy 1500 boards
index 642f0e21d5beb8777cc8ef3bbb135d5dbaf866d8..ee32ddb13f5f462edc1c09e3c3b6f6d744fd0e79 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ define Profile/InternetBox
   NAME:=T-Mobile "InternetBox"
   PACKAGES:=kmod-madwifi \
                ldconfig ldd \
-               hostapd hostapd-utils ip tc wpa-supplicant wpa-cli
+               ip tc wpa-supplicant wpa-cli
 endef
 
 define Profile/InternetBox/Description
index 257f8d0630cf32711f52818c4f4084773b939c33..ddfae679df79364192b00f07139fcfeb79e7ed23 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,8 +9,7 @@ define Profile/MeshCube
   NAME:=MeshCube MTX-1
   PACKAGES:=kmod-madwifi kmod-hostap kmod-hostap-pci kmod-net-prism54 \
        kmod-usb-core kmod-usb-ohci kmod-usb-storage kmod-fs-ext3 kmod-fs-vfat \
-       ldconfig ldd \
-       hostap-utils hostapd hostapd-utils ip tc wpa-supplicant wpa-cli
+       ldconfig ldd hostap-utils ip tc wpa-supplicant wpa-cli
 endef
 
 define Profile/MeshCube/Description
index d721abb13df56d9df42bbc9e9422e2b9900cf10f..c31f9a0db4fec9b06db8b5cf31b099638362e688 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/Atheros
   NAME:=Generic, Atheros WiFi
-  PACKAGES:=kmod-madwifi
+  PACKAGES:=hostapd-mini kmod-madwifi
 endef
 
 define Profile/Atheros/Description
index bad5ec108df5c2a656d37f87591667e17d4b740c..14784f7ed33e6bf00f2972c394802c3910ab2730 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,7 +14,7 @@ FEATURES:=squashfs usb
 LINUX_VERSION:=2.6.25.17
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
+DEFAULT_PACKAGES += hostapd-mini kmod-switch kmod-diag
 
 define Target/Description
        Build firmware images for Broadcom based routers
index 2fcfacde9fa50cefb46f004c0109cb5935ed1235..513366dd724a125f70fb3a8e4fb2a937e9d8d028 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/None
   NAME:=No WiFi
-  PACKAGES:=
+  PACKAGES:=-hostapd-mini
 endef
 
 define Profile/None/Description
index de982abf172e7f94d785a2e939a30d1246283cbd..e4cc65b9c10de18927194992e43da0f246079dbb 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2
 LINUX_VERSION:=2.6.26.5
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips
+DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers
index a4e1a308589c9ed63d15a700466b10a582448a84..882427b92814e8682782f64bfb7df759a368e9e7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,8 +7,7 @@
 
 define Profile/NSLU2
   NAME:=Linksys NSLU2
-  PACKAGES:=kmod-ixp4xx-npe \
-       kmod-scsi-core \
+  PACKAGES:=kmod-ixp4xx-npe -hostapd-mini kmod-scsi-core \
        kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage \
        kmod-fs-ext2 kmod-fs-ext3
 endef
index 21fd5d4696522458c27f8cb546def4aa197179ee..e89cfc4f2340e14e25788eca1f551239724ac443 100644 (file)
@@ -1,5 +1,7 @@
 BOARDNAME:=Generic
 
+DEFAULT_PACKAGES+= hostapd-mini
+
 define Target/Description
        Build firmware images for ixp4xx based boards that boot from internal flash
        (e.g : Linksys NSLU2, ...)
index af5469e6feee263c1d23f379a95595bf3ea5840b..e35b81c7f1fa21b23409452dc0138b875371a329 100644 (file)
@@ -14,6 +14,6 @@ FEATURES:=jffs2 pci tgz
 LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
 
 $(eval $(call BuildTarget))
index d56bac010720a587f993295d6032c5a41d247bac..4567b21f0fa31a85dd1e24ee15b52b3883fcefb0 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,6 +15,8 @@ LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += hostapd-mini
+
 define Target/Description
         Build firmware images for RDC321x based routers
         (e.g. Airlink101 AR525W, Linksys WRT54R, Sitecom WL-153)