htop: moved to github
authorSteven Barth <cyrus@openwrt.org>
Wed, 11 Jun 2014 08:57:38 +0000 (08:57 +0000)
committerSteven Barth <cyrus@openwrt.org>
Wed, 11 Jun 2014 08:57:38 +0000 (08:57 +0000)
SVN-Revision: 41104

admin/htop/Makefile [deleted file]

diff --git a/admin/htop/Makefile b/admin/htop/Makefile
deleted file mode 100644 (file)
index 03c3321..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-#
-# Copyright (C) 2007-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=htop
-PKG_VERSION:=1.0.3
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://hisham.hm/htop/releases/$(PKG_VERSION)/
-PKG_MD5SUM:=e768b9b55c033d9c1dffda72db3a6ac7
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/htop
-  SECTION:=admin
-  CATEGORY:=Administration
-  TITLE:=Interactive processes viewer
-  DEPENDS:=+libncurses
-  URL:=http://htop.sourceforge.net/
-endef
-
-define Package/htop/description
- Htop is an ncursed-based process viewer similar to top, but
- it allows to scroll the list vertically and horizontally to
- see all processes and their full command lines.
-endef
-
-CONFIGURE_ARGS += \
-       --disable-native-affinity \
-       --disable-unicode \
-       --enable-hwloc
-
-CONFIGURE_VARS += \
-       ac_cv_file__proc_stat=yes \
-       ac_cv_file__proc_meminfo=yes \
-       ac_cv_func_malloc_0_nonnull=yes \
-       ac_cv_func_realloc_0_nonnull=yes
-
-define Package/htop/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,htop))