python-ubus: Force old build process
authorJeffery To <jeffery.to@gmail.com>
Mon, 6 Mar 2023 04:04:33 +0000 (12:04 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 24 Apr 2023 08:19:45 +0000 (16:19 +0800)
This package will not build with the pyproject.toml-based build process
because it has a build dependency on pytest-runner[1].

pytest-runner has been deprecated[2], so instead of adding a package for
pytest-runner to fulfill the build dependency, force this package to use
the old build process.

[1]: https://gitlab.nic.cz/turris/python-ubus/-/blob/v0.1.1/setup.py#L35
[2]: https://github.com/pytest-dev/pytest-runner#deprecation-notice

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-ubus/Makefile

index 161440a04f272e5fc42a47949bd5876c42fc73c0..0e96da20c8278fb0eebfc7367813704c98d1bc5a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-ubus
 PKG_VERSION:=0.1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PYPI_NAME:=ubus
 PKG_HASH:=7e57bda989bc35b48c7075d03ec2818226e722bbf1bde138d7e7ea26d462682a
@@ -18,6 +18,8 @@ PKG_MAINTAINER:=Erik Larsson <who+openwrt@cnackers.org>
 PKG_LICENSE:=LGPL-2.1-or-later
 PKG_LICENSE_FILES:=LICENSE
 
+PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1
+
 include ../pypi.mk
 include $(INCLUDE_DIR)/package.mk
 include ../python3-package.mk