backport [5619] to WhiteRussian SDK
authorNicolas Thill <nico@openwrt.org>
Sun, 17 Dec 2006 18:29:24 +0000 (18:29 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 17 Dec 2006 18:29:24 +0000 (18:29 +0000)
SVN-Revision: 5826

openwrt/package/sdk/files/rules.mk

index a4dcaa1fcdbd42f1156be727c27d5fa585f55323..40e414bb1d6b81df5e128f94793f41d8d078f9b1 100644 (file)
@@ -59,6 +59,10 @@ PATCH:=$(SCRIPT_DIR)/patch-kernel.sh
 SED:=$(STAGING_DIR)/bin/sed -i -e
 CP:=cp -fpR
 
+INSTALL_BIN:=install -m0755
+INSTALL_DIR:=install -d -m0755
+INSTALL_DATA:=install -m0644
+
 ifneq ($(CONFIG_CCACHE),)
   # FIXME: move this variable to a better location
   export CCACHE_DIR=$(STAGING_DIR)/ccache