yq: add new package 13873/head
authorTianling Shen <cnsztl@project-openwrt.eu.org>
Sat, 7 Nov 2020 16:51:15 +0000 (00:51 +0800)
committerTianling Shen <cnsztl@project-openwrt.eu.org>
Tue, 10 Nov 2020 04:47:01 +0000 (12:47 +0800)
Signed-off-by: Tianling Shen <cnsztl@project-openwrt.eu.org>
utils/yq/Makefile [new file with mode: 0644]

diff --git a/utils/yq/Makefile b/utils/yq/Makefile
new file mode 100644 (file)
index 0000000..60e852a
--- /dev/null
@@ -0,0 +1,37 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=yq
+PKG_VERSION:=3.4.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/mikefarah/yq/tar.gz/$(PKG_VERSION)?
+PKG_HASH:=73259f808d589d11ea7a18e4cd38a2e98b518a6c2c178d1ec57d9c5942277cb1
+
+PKG_MAINTAINER:=Tianling Shen <cnsztl@project-openwrt.eu.org>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+PKG_USE_MIPS16:=0
+
+GO_PKG:=github.com/mikefarah/yq
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/golang/golang-package.mk
+
+define Package/yq
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Portable command-line YAML processor
+  URL:=https://mikefarah.gitbook.io/yq/
+  DEPENDS:=$(GO_ARCH_DEPENDS)
+endef
+
+define Package/yq/description
+  The aim of the project is to be the jq or sed of yaml files.
+endef
+
+$(eval $(call GoBinPackage,yq))
+$(eval $(call BuildPackage,yq))