dbus: remove dbus-update-activation-environment and add dbus-test-tool 17300/head
authorFlorian Eckert <fe@dev.tdt.de>
Mon, 13 Dec 2021 10:15:18 +0000 (11:15 +0100)
committerFlorian Eckert <fe@dev.tdt.de>
Mon, 13 Dec 2021 10:15:20 +0000 (11:15 +0100)
The tool dbus-update-activiation-environment does not make sense there,
we only use --system service. So this is not needed.

But for debugging we need the tool dbus-test-tool.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
utils/dbus/Makefile

index 9927f0b5947c8c03bac4f8797ff08800a484e4ee..263e8c53f386d46df4aba4ab6de6482de99138ab 100644 (file)
@@ -139,7 +139,9 @@ endef
 
 define Package/dbus-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN)  $(PKG_INSTALL_DIR)/usr/bin/dbus-{monitor,send,update-activation-environment} $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dbus-monitor $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dbus-send $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dbus-test-tool $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libdbus))