bluez: enable static lib, install dev files
authorNicolas Thill <nico@openwrt.org>
Fri, 9 Jan 2015 20:49:14 +0000 (21:49 +0100)
committerNicolas Thill <nico@openwrt.org>
Fri, 9 Jan 2015 20:50:43 +0000 (21:50 +0100)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
utils/bluez/Makefile

index ffd74606c0a703b6e7376272c4a5c56fc70cc395..558a4f85177e5bfb4fef847d65288e8bc9e83006 100644 (file)
@@ -52,6 +52,8 @@ define Package/bluez-utils/conffiles
 endef
 
 CONFIGURE_ARGS += \
+       --enable-static \
+       --enable-shared \
        --enable-client \
        --enable-datafiles \
        --enable-experimental \
@@ -71,6 +73,15 @@ CONFIGURE_ARGS += \
 TARGET_CPPFLAGS += \
        -D_GNU_SOURCE
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/bluetooth $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbluetooth.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/bluez.pc $(1)/usr/lib/pkgconfig/
+endef
+
 define Package/bluez-libs/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbluetooth.so.* $(1)/usr/lib/