python: use built-in libffi lib for host build
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 11 Jan 2017 13:04:03 +0000 (15:04 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 11 Jan 2017 13:12:21 +0000 (15:12 +0200)
Python comes with it's own builtin libffi lib, which
seems easier to use for the host build, than trying
to use the one from the package feeds.

Also, dropping `005-fix-libffi-x86-64-configure.patch`
Not needed anymore.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/Makefile
lang/python/patches/005-fix-libffi-x86-64-configure.patch [deleted file]

index ed708b57821e3c3f8c71909cd370bce0f8ccd1c8..d854be50bf47b7cd8efbda5624b2a3147ec158d0 100644 (file)
@@ -36,7 +36,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
 
 PKG_BUILD_DEPENDS:=python/host
-HOST_BUILD_DEPENDS:=bzip2/host expat/host libffi/host
+HOST_BUILD_DEPENDS:=bzip2/host expat/host
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
@@ -239,7 +239,7 @@ HOST_CONFIGURE_ARGS+= \
        --prefix=$(HOST_PYTHON_DIR) \
        --exec-prefix=$(HOST_PYTHON_DIR) \
        --with-system-expat=$(STAGING_DIR_HOSTPKG) \
-       --with-system-ffi \
+       --with-system-ffi=no \
        CONFIG_SITE=
 
 define Host/Install
diff --git a/lang/python/patches/005-fix-libffi-x86-64-configure.patch b/lang/python/patches/005-fix-libffi-x86-64-configure.patch
deleted file mode 100644 (file)
index ea062a3..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/Modules/_ctypes/libffi/configure b/Modules/_ctypes/libffi/configure
-index 75f62a7..4d6c9f2 100755
---- a/Modules/_ctypes/libffi/configure
-+++ b/Modules/_ctypes/libffi/configure
-@@ -17257,20 +17257,12 @@ case "$host" in
-       fi
-       ;;
--  i?86-*-* | x86_64-*-*)
--      TARGETDIR=x86
--      if test $ac_cv_sizeof_size_t = 4; then
--        case "$host" in
--          *-gnux32)
--            TARGET=X86_64
--            ;;
--          *)
--            TARGET=X86
--            ;;
--          esac
--      else
--        TARGET=X86_64;
--      fi
-+  i?86-*-*)
-+      TARGET=X86; TARGETDIR=x86
-+      ;;
-+
-+  x86_64-*-*)
-+      TARGET=X86_64; TARGETDIR=x86
-       ;;
-   ia64*-*-*)