libre2: update to 2021-02-02
authorRosen Penev <rosenp@gmail.com>
Sun, 21 Mar 2021 01:06:08 +0000 (18:06 -0700)
committerRosen Penev <rosenp@gmail.com>
Sun, 21 Mar 2021 04:08:45 +0000 (21:08 -0700)
Switch to AUTORELEASE for simplicity.

Switch to building with Ninja for faster compilation.

Remove libcxx hacks as it's gone now.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libre2/Makefile
libs/libre2/patches/010-cxx17.patch [deleted file]

index 80495ce257018e771470d97a6f2b9904979bf3ac..44f44af29471f7fb28eecd19c7c2dfeb0355c579 100644 (file)
@@ -1,22 +1,21 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=re2
-PKG_VERSION:=2020-04-01
-PKG_RELEASE:=1
+PKG_VERSION:=2021-02-02
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/google/re2/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=98794bc5416326817498384a9c43cbb5a406bab8da9f84f83c39ecad43ed5cea
+PKG_HASH:=1396ab50c06c1a8885fb68bf49a5ecfd989163015fd96699a180d6414937f33f
 
 PKG_MAINTAINER:=
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
 
 CMAKE_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
+include ../../devel/ninja/ninja-cmake.mk
 
 define Package/re2
   SECTION:=libs
@@ -37,7 +36,6 @@ CMAKE_OPTIONS += \
        -DBUILD_SHARED_LIBS=ON
 
 TARGET_LDFLAGS += \
-       $(if $(CONFIG_USE_GLIBC),-lm) \
        -Wl,--as-needed,--gc-sections
 
 define Package/re2/install
diff --git a/libs/libre2/patches/010-cxx17.patch b/libs/libre2/patches/010-cxx17.patch
deleted file mode 100644 (file)
index ddc3acb..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -38,9 +38,9 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "MSVC")
-   add_compile_options(/utf-8)
- elseif(CYGWIN OR MINGW)
-   # See https://stackoverflow.com/questions/38139631 for details.
--  add_compile_options(-std=gnu++11)
-+  add_compile_options(-std=gnu++17)
- elseif(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
--  add_compile_options(-std=c++11)
-+  add_compile_options(-std=c++17)
- endif()
- if(WIN32)
---- a/re2.pc
-+++ b/re2.pc
-@@ -4,5 +4,5 @@ libdir=@libdir@
- Name: re2
- Description: RE2 is a fast, safe, thread-friendly regular expression engine.
- Version: 0.0.0
--Cflags: -std=c++11 -pthread -I${includedir}
-+Cflags: -std=c++17 -pthread -I${includedir}
- Libs: -pthread -L${libdir} -lre2