ramips: mt7621: ubnt-erx: allow sysupgrade from master
authorPetr Štetiar <ynezz@true.cz>
Mon, 20 Jan 2020 19:36:19 +0000 (20:36 +0100)
committerPetr Štetiar <ynezz@true.cz>
Fri, 24 Jan 2020 07:25:39 +0000 (08:25 +0100)
Currently it's not possible to downgrade from master:

 Device ubiquiti,edgerouterx not supported by this image
 Supported devices: ubnt-erx

So fix it by adding a DTS based device name from master into
SUPPORTED_DEVICES list.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ramips/image/mt7621.mk

index 8efda0784c1ce0aa08557b583e216bf0bfdd9976..9c16705e2fd1a7b05afb2feae2be0e1d5eb6fe8a 100644 (file)
@@ -488,6 +488,7 @@ define Device/ubnt-erx
   KERNEL_INITRAMFS := $$(KERNEL) | ubnt-erx-factory-image $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.tar
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   DEVICE_TITLE := Ubiquiti EdgeRouter X
+  SUPPORTED_DEVICES += ubiquiti,edgerouterx
 endef
 TARGET_DEVICES += ubnt-erx
 
@@ -496,6 +497,7 @@ define Device/ubnt-erx-sfp
   DTS := UBNT-ERX-SFP
   DEVICE_TITLE := Ubiquiti EdgeRouter X-SFP
   DEVICE_PACKAGES += kmod-i2c-algo-pca kmod-gpio-pca953x kmod-i2c-gpio-custom
+  SUPPORTED_DEVICES += ubiquiti,edgerouterx-sfp
 endef
 TARGET_DEVICES += ubnt-erx-sfp