collectd: enable threshold plugin 9601/head
authorFlorian Eckert <fe@dev.tdt.de>
Fri, 8 Feb 2019 13:52:23 +0000 (14:52 +0100)
committerFlorian Eckert <fe@dev.tdt.de>
Tue, 30 Jul 2019 10:36:37 +0000 (12:36 +0200)
The only action the Threshold plugin takes itself is to generate and
dispatch a notification. Other plugins can register to receive
notifications and perform appropriate further actions.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
utils/collectd/Makefile

index 94511271e842d5d350f2a6a88b9db1fd68e24175..b9d30581212db887fe974078b9bdf686d54e3726 100644 (file)
@@ -176,6 +176,7 @@ COLLECTD_PLUGINS_SELECTED:= \
        teamspeak2 \
        ted \
        thermal \
+       threshold \
        unixsock \
        uptime \
        users \
@@ -418,6 +419,7 @@ $(eval $(call BuildPlugin,teamspeak2,TeamSpeak2 input,teamspeak2,))
 $(eval $(call BuildPlugin,ted,The Energy Detective input,ted,))
 $(eval $(call BuildPlugin,tcpconns,TCP connection tracking input,tcpconns,))
 $(eval $(call BuildPlugin,thermal,system temperatures input,thermal,))
+$(eval $(call BuildPlugin,threshold,Notifications and thresholds,threshold,))
 $(eval $(call BuildPlugin,unixsock,unix socket output,unixsock,))
 $(eval $(call BuildPlugin,uptime,uptime status input,uptime,))
 $(eval $(call BuildPlugin,users,user logged in status input,users,))