fuse-overlayfs: add new package 15895/head
authorW. Michael Petullo <mike@flyn.org>
Thu, 17 Jun 2021 20:29:21 +0000 (15:29 -0500)
committerW. Michael Petullo <mike@flyn.org>
Fri, 6 Aug 2021 02:10:45 +0000 (21:10 -0500)
This is part of an attempt to get rootless podman to work on OpenWrt.
See https://github.com/openwrt/packages/issues/15096.

Signed-off-by: W. Michael Petullo <mike@flyn.org>
utils/fuse-overlayfs/Makefile [new file with mode: 0644]

diff --git a/utils/fuse-overlayfs/Makefile b/utils/fuse-overlayfs/Makefile
new file mode 100644 (file)
index 0000000..8cc285f
--- /dev/null
@@ -0,0 +1,39 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fuse-overlayfs
+PKG_VERSION:=1.5.0
+PKG_RELEASE:=$(AUTORELEASE)
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=COPYING
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/containers/fuse-overlayfs/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=6c81b65b71067b303aaa9871f512c2cabc23e2b793f19c6c854d01a492b5a923
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/fuse-overlayfs
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libfuse3
+  TITLE:=fuse-overlayfs
+  URL:=https://github.com/containers/fuse-overlayfs
+endef
+
+define Package/fuse-overlayfs/description
+  FUSE overlay+shiftfs implementation for rootless containers
+endef
+
+define Package/fuse-overlayfs/install
+       $(INSTALL_DIR) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/fuse-overlayfs $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,fuse-overlayfs))