gdbm: configure with `--without-readline`
authorAlois Klink <alois@aloisklink.com>
Wed, 26 Oct 2022 11:59:07 +0000 (12:59 +0100)
committerRosen Penev <rosenp@gmail.com>
Thu, 27 Oct 2022 19:04:00 +0000 (12:04 -0700)
By default, gdbm configures/builds with readline and curses support
if they exist.

This can cause race conditions when compiling gdbm and ncurses in
parallel, as gdbm may try to link to ncurses when it doesn't exist.

This commit forces gdbm to skip using readline/ncurses, since it's
unlikely that anybody is using the line-editing feature of gdbm.

See [gdbm's README][1] for more info.

[1]: https://git.gnu.org.ua/gdbm.git/tree/README?h=v1.21#n50

Signed-off-by: Alois Klink <alois@aloisklink.com>
libs/gdbm/Makefile

index 1155d7365497a1e42ac1ba7792acbe112b77806b..c9be1c5f630f570ec68c271aad38ee2725d239a5 100644 (file)
@@ -39,7 +39,8 @@ endef
 
 CONFIGURE_ARGS += \
        --enable-libgdbm-compat \
-       --enable-shared
+       --enable-shared \
+       --without-readline
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \