mailman: fixed compilation errors (Issue #498) 504/head
authorDenis Shulyaka <Shulyaka@gmail.com>
Tue, 4 Nov 2014 13:58:30 +0000 (16:58 +0300)
committerDenis Shulyaka <Shulyaka@gmail.com>
Tue, 4 Nov 2014 14:03:43 +0000 (17:03 +0300)
Signed-off-by: Denis Shulyaka <Shulyaka@gmail.com>
mail/mailman/Makefile
mail/mailman/patches/300-targetpython.patch [new file with mode: 0644]
mail/mailman/patches/400-modules.patch [new file with mode: 0644]

index c797501661da46d7091901f896d3a78fc6b9e91a..1e85627f204b0f15d8cf77703f5a86804eb0f495 100644 (file)
@@ -40,13 +40,15 @@ endef
 CONFIGURE_ARGS += \
        --prefix="$(prefix)" \
        --exec-prefix="$(prefix)" \
-       --with-python="/usr/bin/python" \
        --with-username="root" \
        --with-groupname="root" \
        --with-mail-gid="nogroup" \
        --with-cgi-gid="root" \
        --without-permcheck \
 
+define Build/Compile
+endef
+
 define Package/mailman/install
        $(INSTALL_DIR) $(1)$(prefix)
        cd $(PKG_BUILD_DIR); $(MAKE) DESTDIR=$(1) install
@@ -89,6 +91,7 @@ if [ -z "$${IPKG_INSTROOT}" ]; then
   ./bin/mmsitepass mailman
   echo "NOTE: The default site password 'mailman' has been created."
  fi
+ # /etc/init.d/mailman enable
  if [ `ps | grep "mailman/bin/qrunner" | grep -cv grep` -gt 0 ]
  then
   $(prefix)/bin/mailmanctl -q restart
@@ -105,7 +108,6 @@ if [ -z "$${IPKG_INSTROOT}" ]; then
   echo "Don't forget to setup firewall for accessing this website!"
   echo "To add a mailing list go to http://$$hostname/mailman/create."
  fi
- # /etc/init.d/mailman enable
 fi
 endef
 
diff --git a/mail/mailman/patches/300-targetpython.patch b/mail/mailman/patches/300-targetpython.patch
new file mode 100644 (file)
index 0000000..1dd2859
--- /dev/null
@@ -0,0 +1,12 @@
+diff -Naur mailman-2.1.18-1/configure mailman-2.1.18-1_patched/configure
+--- mailman-2.1.18-1/configure 2014-05-06 20:43:56.000000000 +0400
++++ mailman-2.1.18-1_patched/configure 2014-11-04 15:02:32.892666331 +0300
+@@ -3927,6 +3927,8 @@
+ $as_echo "$URLHOST" >&6; }
+ rm -f conftest.out conftest.py
++PYTHON=/usr/bin/python
++
+ # Checks for libraries.
+ for ac_func in strerror setregid syslog
diff --git a/mail/mailman/patches/400-modules.patch b/mail/mailman/patches/400-modules.patch
new file mode 100644 (file)
index 0000000..9fa72a2
--- /dev/null
@@ -0,0 +1,35 @@
+diff -Naur mailman-2.1.18-1/Mailman/MailList.py mailman-2.1.18-1_patched/Mailman/MailList.py
+--- mailman-2.1.18-1/Mailman/MailList.py       2014-05-06 20:43:56.000000000 +0400
++++ mailman-2.1.18-1_patched/Mailman/MailList.py       2014-11-04 15:57:06.832636147 +0300
+@@ -30,7 +30,7 @@
+ import shutil
+ import socket
+ import urllib
+-import cPickle
++import pickle as cPickle
+ from cStringIO import StringIO
+ from UserDict import UserDict
+diff -Naur mailman-2.1.18-1/misc/paths.py.in mailman-2.1.18-1_patched/misc/paths.py.in
+--- mailman-2.1.18-1/misc/paths.py.in  2014-05-06 20:43:56.000000000 +0400
++++ mailman-2.1.18-1_patched/misc/paths.py.in  2014-11-04 15:55:49.594941540 +0300
+@@ -66,14 +66,14 @@
+ # In a normal interactive Python environment, the japanese.pth and korean.pth
+ # files would be imported automatically.  But because we inhibit the importing
+ # of the site module, we need to be explicit about importing these codecs.
+-if not jaok:
+-    import japanese
++#if not jaok:
++#    import japanese
+ # As of KoreanCodecs 2.0.5, you had to do the second import to get the Korean
+ # codecs installed, however leave the first import in there in case an upgrade
+ # changes this.
+-if not kook:
+-    import korean
+-    import korean.aliases
++#if not kook:
++#    import korean
++#    import korean.aliases
+ # Arabic and Hebrew (RFC-1556) encoding aliases. (temporary solution)
+ import encodings.aliases
+ encodings.aliases.aliases.update({