icu: update to 68.1 13883/head
authorHirokazu MORIKAWA <morikw2@gmail.com>
Mon, 9 Nov 2020 03:49:56 +0000 (12:49 +0900)
committerHirokazu MORIKAWA <morikw2@gmail.com>
Mon, 9 Nov 2020 03:49:56 +0000 (12:49 +0900)
It updates to CLDR 38. New features including locale-dependent smart unit preferences (road distance, temperature, etc.) and locale ID canonicalization conformant with CLDR.

Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
libs/icu/Makefile
libs/icu/patches/010-max_align_t.patch

index 3fd453de13775bbace2ecb3b48400b7109b4fe86..f2413b9a5cc211421a421a19750e48e686c282d9 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=icu4c
-MAJOR_VERSION:=67
+MAJOR_VERSION:=68
 MINOR_VERSION:=1
 PKG_VERSION:=$(MAJOR_VERSION).$(MINOR_VERSION)
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(MAJOR_VERSION)_$(MINOR_VERSION)-src.tgz
 PKG_SOURCE_URL:=https://github.com/unicode-org/icu/releases/download/release-$(MAJOR_VERSION)-$(MINOR_VERSION)
-PKG_HASH:=94a80cd6f251a53bd2a997f6f1b5ac6653fe791dfab66e1eb0227740fb86d5dc
+PKG_HASH:=a9f2e3d8b4434b8e53878b4308bd1e6ee51c9c7042e2b1a376abefb6fbb29f2d
 
 PKG_LICENSE:=ICU
 PKG_LICENSE_FILES:=LICENSE
index 3c0495184a0219b24ff2d0aa2e9ade3083e8deb8..0ad406b41f84a5c9f393782cd9b1a38095e62a8d 100644 (file)
@@ -49,7 +49,7 @@
          if (ut == NULL) {
 --- a/tools/toolutil/toolutil.cpp
 +++ b/tools/toolutil/toolutil.cpp
-@@ -245,7 +245,7 @@ struct UToolMemory {
+@@ -242,7 +242,7 @@ struct UToolMemory {
      char name[64];
      int32_t capacity, maxCapacity, size, idx;
      void *array;