iproute2: q_cake: Also print nonat, nowash and no-ack-filter keywords
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Fri, 14 Sep 2018 20:52:39 +0000 (21:52 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Sat, 15 Sep 2018 07:49:36 +0000 (08:49 +0100)
Pull in latest upstream tweaks:
Similar to the previous patch for no-split-gso, the negative keywords for
'nat', 'wash' and 'ack-filter' were not printed either. Add those as well.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
(cherry picked from commit 033f02b9b5580e67e2f1b623f62da60d645e7ba2)

package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/950-add-cake-to-tc.patch

index 91092b2f51793829315f402bd62e9857d225eef7..2c13e276fbede965ae963863586ae6b77f482a13 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=4.16.0
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
index 038ca2333768005ccf499f84e7aca77283749d7c..1eebb729c3ce7cdc4402a9fc5e1c0601ad217d24 100644 (file)
  TCMODULES += e_bpf.o
 --- /dev/null
 +++ b/tc/q_cake.c
-@@ -0,0 +1,801 @@
+@@ -0,0 +1,805 @@
 +// SPDX-License-Identifier: GPL-2.0 OR BSD-3-Clause
 +
 +/*
 +
 +      if (nat)
 +              print_string(PRINT_FP, NULL, "nat ", NULL);
++      else
++              print_string(PRINT_FP, NULL, "nonat ", NULL);
 +      print_bool(PRINT_JSON, "nat", NULL, nat);
 +
 +      if (tb[TCA_CAKE_WASH] &&
 +
 +      if (wash)
 +              print_string(PRINT_FP, NULL, "wash ", NULL);
++      else
++              print_string(PRINT_FP, NULL, "nowash ", NULL);
 +      print_bool(PRINT_JSON, "wash", NULL, wash);
 +
 +      if (ingress)
 +      else if (ack_filter == CAKE_ACK_FILTER)
 +              print_string(PRINT_ANY, "ack-filter", "ack-filter ", "enabled");
 +      else
-+              print_string(PRINT_JSON, "ack-filter", NULL, "disabled");
++              print_string(PRINT_ANY, "ack-filter", "no-ack-filter ", "disabled");
 +
 +      if (split_gso)
 +              print_string(PRINT_FP, NULL, "split-gso ", NULL);