[packages] Introduce php5-pecl-libevent package
authorFlorian Fainelli <florian@openwrt.org>
Mon, 21 Jan 2013 15:27:48 +0000 (15:27 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 21 Jan 2013 15:27:48 +0000 (15:27 +0000)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 35277

lang/php5-pecl-libevent/Makefile [new file with mode: 0644]

diff --git a/lang/php5-pecl-libevent/Makefile b/lang/php5-pecl-libevent/Makefile
new file mode 100644 (file)
index 0000000..3358c9e
--- /dev/null
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PECL_NAME:=libevent
+PECL_LONGNAME:=Libevent - event notification
+
+PKG_VERSION:=0.0.5
+PKG_RELEASE:=1
+PKG_MD5SUM:=5539f4e1f44879d5a9afae7d75a96112
+
+PKG_NAME:=php5-pecl-$(PECL_NAME)
+PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://pecl.php.net/get/
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PECL_NAME)-$(PKG_VERSION)
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+include ../php5/pecl.mk
+
+CONFIGURE_ARGS+= --with-libevent=shared,"$(STAGING_DIR)/usr"
+
+$(eval $(call PECLPackage,$(PECL_NAME),$(PECL_LONGNAME),+libevent))
+$(eval $(call BuildPackage,$(PKG_NAME)))