freeswitch-stable: cleanup after move to system libtiff
authorSebastian Kemper <sebastian_ml@gmx.net>
Sat, 3 Feb 2018 18:28:22 +0000 (19:28 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sat, 3 Feb 2018 18:29:23 +0000 (19:29 +0100)
- refresh a patch
- drop depend on liblzma from mod-gsmopen
- add tiff to PKG_BUILD_DEPENDS

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/freeswitch-stable/Makefile
net/freeswitch-stable/patches/310-use-system-tiff.patch

index 7d752e1a40c8548f99c2f4341be7e234431c974e..f0ca8c05cc409ce36f112b044b5835369e064f4c 100644 (file)
@@ -19,9 +19,10 @@ PKG_HASH:=dbb0f73109171bd381772b247b8ef581f6a176964619082a1fe031b004086f6b
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PRG_NAME)-$(PKG_VERSION)
 
-# configure fails without libjpeg, but it's only needed for mod_spandsp
+# configure in libs/spandsp fails without libjpeg and tiff
 PKG_BUILD_DEPENDS:= \
        libjpeg \
+       tiff \
        perl/host \
        python/host
 
@@ -1169,7 +1170,7 @@ $(eval $(call Package/$(PKG_NAME)/Module,fsv,FSV,This module provides dialplan a
 $(eval $(call Package/$(PKG_NAME)/Module,g723_1,G.723.1 passthrough,G.723.1 codec passthrough.,))
 $(eval $(call Package/$(PKG_NAME)/Module,g729,G.729 passthrough,G.729 codec passthrough.,))
 $(eval $(call Package/$(PKG_NAME)/Module,graylog2,Graylog2 logger,GELF logger for Graylog2 and Logstash.,))
-$(eval $(call Package/$(PKG_NAME)/Module,gsmopen,GSM endpoint,GSMopen is a channel driver that allows an SMS to be sent to and from\nFreeSWITCH as well as incoming and outgoing GSM voice calls.,+gsmlib +libctb +libjpeg +liblzma +libtiff))
+$(eval $(call Package/$(PKG_NAME)/Module,gsmopen,GSM endpoint,GSMopen is a channel driver that allows an SMS to be sent to and from\nFreeSWITCH as well as incoming and outgoing GSM voice calls.,+gsmlib +libctb +libjpeg +libtiff))
 $(eval $(call Package/$(PKG_NAME)/Module,h26x,H.26x passthrough,H.26x video codec passthrough.,))
 $(eval $(call Package/$(PKG_NAME)/Module,hash,Hash,This module provides a key-value in-memory datastore. Usable as a\nlimit backend.,))
 $(eval $(call Package/$(PKG_NAME)/Module,hiredis,Redis client,This module provides a mechanism to use Redis as a datastore.,+libhiredis))
index e7e1ac6c8852444980f8d1e88f4646fa42e67d5b..1fcb02959b6d49edfade5b8d575036007402ec80 100644 (file)
@@ -37,7 +37,7 @@ Date:   Tue Mar 14 17:39:05 2017 -0500
        cd libs/spandsp && sh ./configure.gnu $(MY_DEFAULT_ARGS)
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1984,7 +1984,6 @@ AC_CONFIG_SUBDIRS([libs/libdingaling])
+@@ -1969,7 +1969,6 @@ AC_CONFIG_SUBDIRS([libs/libdingaling])
  AC_CONFIG_SUBDIRS([libs/sofia-sip])
  AC_CONFIG_SUBDIRS([libs/freetdm])
  AC_CONFIG_SUBDIRS([libs/unimrcp])