[packages] openvpn: accept both "option enable" and "option enabled"
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 29 Nov 2011 15:58:17 +0000 (15:58 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 29 Nov 2011 15:58:17 +0000 (15:58 +0000)
SVN-Revision: 29355

net/openvpn/Makefile
net/openvpn/files/openvpn.init

index 53dcd98119d1dd5082a91578ee7571ae6cf1d5fc..c80c587e2297292afcf6b09627b0f93869e9c915 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openvpn
 PKG_VERSION:=2.2.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://swupdate.openvpn.net/community/releases @SF/openvpn
index 3ff1cd6923ff2e7af764c47b89730d37545bd3ca..c5f3f95ca8afb03fe8bcb922f781263422b344ef 100644 (file)
@@ -58,8 +58,9 @@ append_params_quoted() {
 }
 
 section_enabled() {
+       config_get_bool enable  "$1" 'enable'  0
        config_get_bool enabled "$1" 'enabled' 0
-       [ $enabled -gt 0 ]
+       [ $enable -gt 0 ] || [ $enabled -gt 0 ]
 }
 
 start_instance() {