With eglibc needs to define -D_GNU_SOURCE in cflags to avoid following error:
authorMirko Vogt <mirko@openwrt.org>
Mon, 6 Aug 2012 11:07:38 +0000 (11:07 +0000)
committerMirko Vogt <mirko@openwrt.org>
Mon, 6 Aug 2012 11:07:38 +0000 (11:07 +0000)
  CC      build-mips/sa/pton.o
src/sa/pton.c: In function 'net_inet_pton':
src/sa/pton.c:233:7: error: 'const struct in6_addr' has no member named 's6_addr32'
src/sa/pton.c:233:7: error: 'const struct in6_addr' has no member named 's6_addr32'
src/sa/pton.c:233:7: error: 'const struct in6_addr' has no member named 's6_addr32'

Signed-off-by: Mika Laitio <mika.laitio@nokia.com>
SVN-Revision: 33008

libs/re/Makefile

index c3cc27bef435749ff4b2bdc0f235f33355a991d1..fbafd4713f229ccb0c597313f1753e6151993242 100644 (file)
@@ -28,6 +28,10 @@ endef
 
 TARGET_CFLAGS += $(FPIC)
 
+ifneq ($(CONFIG_USE_EGLIBC),)
+TARGET_CFLAGS += -D_GNU_SOURCE
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                HAVE_LIBRESOLV= \