sox: depends on alsa-lib and libsndfile
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 13 Jun 2012 00:22:26 +0000 (00:22 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 13 Jun 2012 00:22:26 +0000 (00:22 +0000)
SVN-Revision: 32317

sound/mocp/Makefile
sound/sox/Makefile

index c3437760344b915a60c35fe220cd6b54967d6660..4875adf1adc912519605eb9d3ae74241f9ba432d 100644 (file)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/nls.mk
 define Package/moc
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libcurl +BUILD_PATENTED:libmad +libvorbis $(ICONV_DEPENDS) +alsa-utils +libid3tag +libflac +libsamplerate +PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libffmpeg
+  DEPENDS:=+libcurl +BUILD_PATENTED:libmad +libvorbis $(ICONV_DEPENDS) +alsa-utils +libid3tag +libflac +libsamplerate +PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libffmpeg-mini
   TITLE:=Music On Console
   URL:=http://moc.daper.net/
 endef
index 30e78f005e08b3e7d7f6a2c66b6b154afdef5474..ee501f8180802fccc5861c4fb0540b418b014f16 100644 (file)
@@ -30,7 +30,7 @@ TARGET_LDFLAGS+= \
 define Package/sox
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+BUILD_PATENTED:lame-lib +BUILD_PATENTED:libmad +BUILD_PATENTED:libid3tag +libvorbis +libvorbisidec +libgsm
+  DEPENDS:=+BUILD_PATENTED:lame-lib +BUILD_PATENTED:libmad +BUILD_PATENTED:libid3tag +libvorbis +libvorbisidec +libgsm +alsa-lib +libsndfile
   TITLE:=Sox is a general purpose sound converter/player/recorder
   URL:=http://sox.sourceforge.net/
 endef