net/nut: Add back serial support
authorDaniel Dickinson <lede@cshore.thecshore.com>
Wed, 11 Jan 2017 23:54:29 +0000 (18:54 -0500)
committerDaniel Dickinson <lede@cshore.thecshore.com>
Wed, 11 Jan 2017 23:54:29 +0000 (18:54 -0500)
It looks like serial support was accidentally dropped due to missing
pieces on Config.in and Makefile.  Add back serial support by fixing
that.

Signed-off-by: Daniel Dickinson <lede@cshore.thecshore.com>
net/nut/Config.in
net/nut/Makefile

index a5f1ff4bec706139c1004f16eee8e674af30844e..b7f403b782012f7a422ed6dc4b8e56c257e51029 100644 (file)
                help
                        If you have a UPS you can connect to via SNMP, select this.
                default n
+
+       config NUT_DRIVER_SERIAL
+               depends on PACKAGE_nut
+               bool "Build with suport for serial drivers"
+               help
+                       If you have a UPS connected via serial cable, select this.
+               default n
index a5773f1f8d3c7de7f3c7332726abf51ed4e490b2..25d93c48dd29b2cce5db2b51ac1bd87618756eed 100644 (file)
@@ -24,6 +24,7 @@ PKG_INSTALL:=1
 PKG_CONFIG_DEPENDS:= \
        CONFIG_NUT_DRIVER_SNMP \
        CONFIG_NUT_DRIVER_USB \
+       CONFIG_NUT_DRIVER_SERIAL \
        CONFIG_NUT_SSL
 
 include $(INCLUDE_DIR)/package.mk
@@ -323,6 +324,7 @@ define DriverPackage
                DEPENDS:=nut +nut-common
                $(if $(filter $(1),snmp),DEPENDS+= @NUT_DRIVER_SNMP)
                $(if $(filter $(1),usb),DEPENDS+= @NUT_DRIVER_USB)
+               $(if $(filter $(1),serial),DEPENDS+= @NUT_DRIVER_SERIAL)
         endef
        # Deliberately empty description in order to trigger a build failure.
        # It should be overridden by the list below, and when updating to a
@@ -478,6 +480,7 @@ CONFIGURE_ARGS += \
        --$(if $(CONFIG_NUT_DRIVER_USB),with,without)-usb \
        --without-avahi \
        --$(if $(CONFIG_NUT_DRIVER_SNMP),with,without)-snmp \
+       --$(if $(CONFIG_NUT_DRIVER_SERAL),with,without)-serial \
        --without-neon \
        --without-powerman \
        --with-cgi \