elfutils: remove argp-standalone dependency
authorFlorian Fainelli <florian@openwrt.org>
Mon, 11 Feb 2013 16:03:09 +0000 (16:03 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 11 Feb 2013 16:03:09 +0000 (16:03 +0000)
It is required only when building elfutils binaries (readelf, ld ...)
but not the library itself.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 35558

libs/elfutils/Makefile

index 449e790c4c6057bf2fe974fc40e188690556f722..0aa8d7786698dbd9e4e3a2f14c4df92072a62b0c 100644 (file)
@@ -16,8 +16,6 @@ PKG_MD5SUM:=163a5712b86f6bdfebdf233cc6e2192d
 
 PKG_INSTALL:=1
 
-PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone
-
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
@@ -44,11 +42,6 @@ ifeq ($(CONFIG_BUILD_NLS),y)
 TARGET_LDFLAGS += "-lintl"
 endif
 
-ifdef CONFIG_USE_UCLIBC
-CONFIGURE_VARS += \
-       LIBS="-largp"
-endif
-
 CONFIGURE_ARGS += \
        --disable-werror