[packages] dsniff: fix build
authorPeter Wagner <​tripolar@gmx.at>
Sun, 10 Nov 2013 18:18:14 +0000 (18:18 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Sun, 10 Nov 2013 18:18:14 +0000 (18:18 +0000)
Signed-off-by: Peter Wagner <tripolar@gmx.at>
SVN-Revision: 38710

net/dsniff/Makefile
net/dsniff/patches/011-noint32.patch [new file with mode: 0644]

index 1c07c34cd3abc0a9a38388b7c2f4fc68f01008fc..8f4c331f1c162bae8f65d0ba601fb679fdd58a16 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dsniff
 PKG_VERSION:=2.4b1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.monkey.org/~dugsong/dsniff/beta
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dsniff
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcap +libnids +libnet0 +libopenssl +libgdbm $(LIBRPC_DEPENDS) @BROKEN
+  DEPENDS:=+libpcap +libnids +libnet1 +libopenssl +libgdbm $(LIBRPC_DEPENDS)
   TITLE:=A collection of tools for network auditing and penetration testing
   URL:=http://www.monkey.org/~dugsong/dsniff/
 endef
diff --git a/net/dsniff/patches/011-noint32.patch b/net/dsniff/patches/011-noint32.patch
new file mode 100644 (file)
index 0000000..4fef5a8
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/nfs_prot.x b/nfs_prot.x
+index 1111dcc..f7392eb 100644
+--- a/nfs_prot.x
++++ b/nfs_prot.x
+@@ -193,7 +193,6 @@ const NFS3_WRITEVERFSIZE  = 8;
+ typedef u_int64_t     uint64;
+ typedef int64_t               int64;
+ typedef unsigned int  uint32;
+-typedef int           int32;
+ typedef string                filename3<>;
+ typedef string                nfspath3<>;
+ typedef uint64                fileid3;