click: Update to 8.1.4, rename source package
authorJeffery To <jeffery.to@gmail.com>
Thu, 13 Jul 2023 08:31:57 +0000 (16:31 +0800)
committerRosen Penev <rosenp@gmail.com>
Thu, 13 Jul 2023 23:17:32 +0000 (16:17 -0700)
This renames the source package to python-click to match other Python
packages.

This also updates the package dependencies, licence file, package title
and description.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/click/Makefile [deleted file]
lang/python/python-click/Makefile [new file with mode: 0644]

diff --git a/lang/python/click/Makefile b/lang/python/click/Makefile
deleted file mode 100644 (file)
index 39bf929..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=click
-PKG_VERSION:=8.1.3
-PKG_RELEASE:=1
-
-PYPI_NAME:=click
-PKG_HASH:=7682dc8afb30297001674575ea00d1814d808d6a36af415a82bd481d37ba7b8e
-
-PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
-PKG_LICENSE:=BSD-3-Clause
-PKG_LICENSE_FILES:=LICENSE
-
-include ../pypi.mk
-include $(INCLUDE_DIR)/package.mk
-include ../python3-package.mk
-
-define Package/python3-click
-  SECTION:=lang
-  CATEGORY:=Languages
-  SUBMENU:=Python
-  TITLE:=Click
-  URL:=https://palletsprojects.com/p/click/
-  DEPENDS:=+python3-light
-endef
-
-define Package/python3-click/description
-  Composable command line interface toolkit
-endef
-
-$(eval $(call Py3Package,python3-click))
-$(eval $(call BuildPackage,python3-click))
-$(eval $(call BuildPackage,python3-click-src))
diff --git a/lang/python/python-click/Makefile b/lang/python/python-click/Makefile
new file mode 100644 (file)
index 0000000..47134d2
--- /dev/null
@@ -0,0 +1,40 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-click
+PKG_VERSION:=8.1.4
+PKG_RELEASE:=1
+
+PYPI_NAME:=click
+PKG_HASH:=b97d0c74955da062a7d4ef92fadb583806a585b2ea81958a81bd72726cbb8e37
+
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE.rst
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-click
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=Composable command line interface toolkit
+  URL:=https://palletsprojects.com/p/click/
+  DEPENDS:=+python3-light +python3-urllib +python3-uuid
+endef
+
+define Package/python3-click/description
+Click is a Python package for creating beautiful command line interfaces
+in a composable way with as little code as necessary. It's the "Command
+Line Interface Creation Kit". It's highly configurable but comes with
+sensible defaults out of the box.
+endef
+
+$(eval $(call Py3Package,python3-click))
+$(eval $(call BuildPackage,python3-click))
+$(eval $(call BuildPackage,python3-click-src))