svox: fix compilation with newer musl 11602/head
authorRosen Penev <rosenp@gmail.com>
Fri, 20 Mar 2020 05:01:41 +0000 (22:01 -0700)
committerRosen Penev <rosenp@gmail.com>
Fri, 20 Mar 2020 06:38:45 +0000 (23:38 -0700)
Otherwise int8_t is undeclared.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
sound/svox/Makefile
sound/svox/patches/0003-pico2wave-Convert-text-to-.wav-using-svox-text-to-sp.patch

index 3587a7c75fce187ec38356c9d3e10c7c71a735f1..2417bfc9d10dda03bc286520ea172e9ba382f986 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=svox
 PKG_VERSION:=1.0+git20130326
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/non-free/s/svox
index c8a2e83991a2f41acd32417abedae7ec4c3148e4..19b6df1b9130d07f2a81b45acd179a5cec042d4b 100644 (file)
@@ -41,7 +41,7 @@ new file mode 100644
 index 0000000..0c035a7
 --- /dev/null
 +++ b/pico/bin/pico2wave.c
-@@ -0,0 +1,341 @@
+@@ -0,0 +1,342 @@
 +/* pico2wave.c
 +
 + * Copyright (C) 2009 Mathieu Parent <math.parent@gmail.com>
@@ -65,6 +65,7 @@ index 0000000..0c035a7
 +
 +#include <popt.h>
 +#include <stdio.h>
++#include <stdint.h>
 +#include <stdlib.h>
 +#include <string.h>
 +